While I agree that function names should be intuitive, I wouldn't exaggerate. Long names are more difficult to read, write and remember; in my opinion they are only worth the drawbacks when they really increase the expressivity.
And I think that
sf::Time time = sf::Seconds(4);
is perfectly expressive, as well as
sf::Sleep(sf::Seconds(4));
On the other side, things like
sf::Time t = sf::Time::FromSeconds(4);
or
sf::Sleep(sf::Time::FromSeconds(4))
are heavy and contain duplicate information, but don't give us more information about the semantics. At least no useful one -- we see that a sf::Time object is constructed, but since sf::Time is the only SFML time class, this is obvious. Additionally, the exactly returned type isn't that important.
Also concerning sf::TimeSpan: While it is useful to differ between time points and time spans (like duration in Boost/Std), SFML doesn't have this concept, so I consider sf::Time general enough.