SFML community forums

Help => Graphics => Topic started by: typeoneerror on January 01, 2014, 01:32:17 am

Title: Freetype malformed framework
Post by: typeoneerror on January 01, 2014, 01:32:17 am
We just wrapped up a game in SFML for Mac and submitted it to the Mac store. We are using SFML 2.0. We're using a standard SFML project in Xcode with the link script that copies over the required frameworks. The game works great on all computers from Mac OSX 10.6-10.9. Trouble is, when we submit to the App Store, we get an email back saying the following:

Malformed Framework - The framework bundle (Shibashiba.app/Contents/Frameworks/freetype.framework) must contain a symbolic link 'freetype' -> 'Versions/Current/freetype'. Refer to the Anatomy of Framework Bundles for more information.

If I go into the Archived application, the freetype.framework folder is in Contents/Frameworks and it has a symbolic link that points to Versions/Current/freetype, so I'm at a loss as to what this error means. Could it be some kind of permissions error? Could the freetype distro included with 2.0 be messed up in some way? Any help would be appreciated. This is our last hurdle to shipping!
Title: Re: Freetype malformed framework
Post by: typeoneerror on January 02, 2014, 05:55:54 am
Pretty sure the freetype framework is incorrectly set up. I've answered a question on stack overflow on why:


Also filed a bug on github just in case any one else runs into this issue.
Title: Re: Freetype malformed framework
Post by: kipbits on December 14, 2015, 03:01:20 am
I'm wondering if I am having the same problem? I had an issue with a code-siginig failure for freetype when signing my project. I fixed the error by using the flag --deep. But when I go to upload to the app store i get a validation error:

Couldn't find platform family in Info.plist CFBundleSupportedPlatforms or Mach-O LC_VERSION_MIN for A

any Ideas?

I've tried copy-pasting the linker commands
   cd /Library/Frameworks/freetype.framework
   ln -fns Versions/Current/freetype freetype
in the terminal. I still get the same error when I go to build and sign my project. What am I doing wrong?

   I've added a new thread (http://en.sfml-dev.org/forums/index.php?topic=19498.0) for my related problem.