Use consistent naming convention. And This_Style is very unusual.
Have a clear rule when to use reference and pointer parameters.
Use const for references that provide no access to modify the object (e.g. font parameter).
Avoid magic numbers (checkIfClicked()), use loops to avoid code duplication.
Indent consistently (if/else on same or different line).
Use spaces consistently, especially between operators.
You could use the sf::Drawable base class.
As you see, there are a lot of formatting-related issues, which makes the code quickly unreadable and harder to understand. Make sure these things are fixed before asking about semantics...