Copy constructor and assignment operator are flawed. Make the class non-copyable if you don't want copies. But providing copy ctor and op= without implementing them is a bad idea.
Thanks I forgot that. They were added by the IDE, but at some point I just forgot they were there and didn't even bother to program them when I do need them to have a copy constructor and assignment operator.
You could directly use VertexHolder[I++].texCoords = ...
I removed this while debugging in order to be able to make console printing of the data to make sure they were being copied or assigned correctly (oddly enough, most of what went wrong was there). When I was using pos-increment I always had the problem of not being able to check the first vertex of the quad (the first time the function was being run) was correctly assigned or not, so I switched to pre-increment and left it that way, but there should be no reason for it now.
The == and != operators needn't be friends.
Why not? The static value they are using for float comparison is private, so to my understanding they need to be friends of the class to use it. I could make it public of course, but that would only mean that it'd be like a needless global variable.
This specific EPSILON could be used for other classes, but it would leave a naming inconsistency (which is already enough as it is with my bad namings). And there's also the benefit of being able to change how much precision you want to use for the class's (and only that class) comparison by changing the value without affecting other possible classes that use this EPSILON in case it where either a public static or a purely global variable.
Not to mention that the only globals I have are there out of necessity for some calculations so that the code hasn't any other dependencies, adding another one would be dirty in my opinion since that part should be changed in anything serious by either using thor's math module (not used to lessen the amount of dependencies) or a self made file used specifically to store all necessary calculation globals such as Pi and any other mathematic constant needed. I just thought it unnecessary to add such a file when the programmer may already have his own.
The variables are named inconsistently.
I guess this will be my forever flaw, I've always sucked at thinking in good and expressive names.
They're all overall good suggestions. I'll take them into account and assimilate them into my coding. There's always something to improve.