Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: The application was unable to start correctly (oxcooooo7b).  (Read 9853 times)

0 Members and 1 Guest are viewing this topic.

beauxq

  • Newbie
  • *
  • Posts: 7
    • View Profile
The application was unable to start correctly (oxcooooo7b).
« on: December 20, 2014, 06:54:16 pm »
Code::Blocks 13.12
TDM-GCC TDM64 MinGW-w64 4.9.2 64-bit
SFML GCC 4.9.2 MinGW (SEH) - 64-bit
Windows 7 64-bit

Just following the instructions on this tutorial page: http://www.sfml-dev.org/tutorials/2.2/start-cb.php

it compiles and runs and says

sfmltest.exe - Application Error
The application was unable to start correctly (oxcooooo7b). Click OK to close the application.
« Last Edit: December 20, 2014, 07:11:32 pm by beauxq »

Hapax

  • Hero Member
  • *****
  • Posts: 3372
  • My number of posts is shown in hexadecimal.
    • View Profile
    • Links
Re: The application was unable to start correctly (oxcooooo7b).
« Reply #1 on: December 20, 2014, 07:00:16 pm »
Googling the error (which you should have already done), I found that one cause could be a 32-bit/64-bit clash.
Are you sure your OS, compiled code, and the libraries that you're including are all equal?

If you are sure, read the rest of this article (it was the first result I got from googling that error). It could give you some clues.
Selba Ward -SFML drawables
Cheese Map -Drawable Layered Tile Map
Kairos -Timing Library
Grambol
 *Hapaxia Links*

beauxq

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: The application was unable to start correctly (oxcooooo7b).
« Reply #2 on: December 20, 2014, 07:09:40 pm »
I suspected that. That's why I posted my compiler version and SFML version - both 64 bit.
What else could i be missing that might be trying to use 32-bit?

beauxq

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: The application was unable to start correctly (oxcooooo7b).
« Reply #3 on: December 20, 2014, 07:14:34 pm »
I compile other code in the same environment and it works fine.
It's just when using SFML, that I get this problem.

beauxq

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: The application was unable to start correctly (oxcooooo7b).
« Reply #4 on: December 20, 2014, 07:22:39 pm »
If i use a 4.7.1 compiler, then I can get SFML to work, following the same tutorial.

But for what i want to do, I need 4.9.2


Hapax

  • Hero Member
  • *****
  • Posts: 3372
  • My number of posts is shown in hexadecimal.
    • View Profile
    • Links
Re: The application was unable to start correctly (oxcooooo7b).
« Reply #5 on: December 20, 2014, 08:02:25 pm »
Are you sure that your SFML libraries are also the 64-bit version? If the problem only occurs when SFML is involved, it's worth checking for certain that they are the exact version required.

Did you read that article that I linked? It suggests many other possible solutions, such as reinstalling IDE or running as admin.
Selba Ward -SFML drawables
Cheese Map -Drawable Layered Tile Map
Kairos -Timing Library
Grambol
 *Hapaxia Links*

beauxq

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: The application was unable to start correctly (oxcooooo7b).
« Reply #6 on: December 20, 2014, 08:10:55 pm »
I just discovered that if I purposefully mix wrong versions, it works.

I put the

4.9.2 64-bit compiler together with the
4.7.1 32-bit SFML,

and the program ran correctly.

I guess I could keep trying to use it like that. I don't know what problems I might come across later from mixing them.

But I can't find any way to get the 4.9.2 SFML to work.

wintertime

  • Sr. Member
  • ****
  • Posts: 255
    • View Profile
Re: The application was unable to start correctly (oxcooooo7b).
« Reply #7 on: December 21, 2014, 12:30:40 pm »
Did you accidentally put an -m32 switch when building your app, making it behave as 32bit compiler?

dabbertorres

  • Hero Member
  • *****
  • Posts: 506
    • View Profile
    • website/blog
Re: The application was unable to start correctly (oxcooooo7b).
« Reply #8 on: December 21, 2014, 06:41:27 pm »
iirc, TDM-GCC doesn't provide a SEH version of the compiler, only SJLJ and DW2, I think that's the reason here. You should just try compiling SFML yourself.

wintertime

  • Sr. Member
  • ****
  • Posts: 255
    • View Profile
Re: The application was unable to start correctly (oxcooooo7b).
« Reply #9 on: December 22, 2014, 11:04:07 am »
It does use SEH in 64bit mode: http://tdm-gcc.tdragon.net/quirks
I would clean the system and then only install one version of the compiler, library, dlls.

eXpl0it3r

  • SFML Team
  • Hero Member
  • *****
  • Posts: 10936
    • View Profile
    • development blog
    • Email
AW: Re: The application was unable to start correctly (oxcooooo7b).
« Reply #10 on: December 22, 2014, 11:26:28 am »
It does use SEH in 64bit mode: http://tdm-gcc.tdragon.net/quirks
I guess there's an error then on the SFML download page. The TDM 4.8.1 x64 is using SEH.
Will fix it later today.

As for topic: Either use the builds that 100% match your compiler OR build from source, everything else will fail sooner or later.
Official FAQ: https://www.sfml-dev.org/faq.php
Official Discord Server: https://discord.gg/nr4X7Fh
——————————————————————
Dev Blog: https://duerrenberger.dev/blog/

 

anything