Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: [soloved] Linking Problem - Debug Mode - Windows  (Read 2623 times)

0 Members and 1 Guest are viewing this topic.

PhiLLe

  • Newbie
  • *
  • Posts: 36
    • View Profile
[soloved] Linking Problem - Debug Mode - Windows
« on: October 09, 2009, 04:31:23 pm »
Hello!

I am trying to compile a simple SFML application.
I am working with Visual Studio 2008 Express under Vista.

My steps:
1) Create a console Project
2) Write the code:
Code: [Select]
#include <SFML/Window.hpp>

int main()
{
    // Create the main window
    sf::Window App(sf::VideoMode(640, 480, 32), "SFML", sf::Style::Close);

    App.ShowMouseCursor(false);

    // Start main loop
    while (App.IsOpened())
    {
        // Process events
        sf::Event Event;
        while (App.GetEvent(Event))
        {
            // Close window : exit
            if (Event.Type == sf::Event::Closed)
                App.Close();

            // Escape key : exit
            if ((Event.Type == sf::Event::KeyPressed) && (Event.Key.Code == sf::Key::Escape))
                App.Close();
        }

        App.Display();
    }

    return EXIT_SUCCESS;
}

3) Compile

I am linking to these libraries:
Debug:
sfml-system-s-d.lib sfml-window-s-d.lib
Release:
sfml-system-s.lib sfml-window-s.lib

Everything works in the Release mode. But there are some warnings when I compile in the Debug mode:
Quote
sfml-system-s-d.lib(Platform.obj) : warning LNK4099: PDB "vc90.pdb" wurde nicht mit "..\..\xxx\lib\vc2008\sfml-system-s-d.lib" oder an "xxx\win\Debug\vc90.pdb" gefunden; Objekt wird verknüpft, als ob keine Debuginformationen vorhanden wären.

Its kind of sad that it is in German :(

Well thats only a warning. I can run it without problems. But just one time. When I rebuild it the Program asks for a .dll:
MSVCP90D.dll

Very Strange...

Can anybody help me?
Greetings

Edit:
I solved it! I just had to build sfml by myseld and it worked fine.

 

anything