Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: SFML and OpenGL ES 2.0 context  (Read 2027 times)

0 Members and 1 Guest are viewing this topic.

Lichi

  • Newbie
  • *
  • Posts: 1
    • View Profile
    • Email
SFML and OpenGL ES 2.0 context
« on: October 14, 2016, 03:09:22 am »
Hi, i'm doing a cross-platform game (should work on android), i'm using sf::shaders for some effects, but I can't use sf::shaders in android because sfml uses opengl ES 1.1(wich not supports shaders), I want to know if there is any way to use SFML with opengl ES 2.0 context, or if it's planned to update SFML's opengl ES to 2.0.
Thanks.

Laurent

  • Administrator
  • Hero Member
  • *****
  • Posts: 32009
    • View Profile
    • SFML's website
    • Email
Re: SFML and OpenGL ES 2.0 context
« Reply #1 on: October 14, 2016, 06:27:25 am »
No it is not possible, and yes we'll eventually switch to modern OpenGL on all supported platforms ;)
Laurent Gomila - SFML developer

oomek

  • Jr. Member
  • **
  • Posts: 80
    • View Profile
    • Email
Re: SFML and OpenGL ES 2.0 context
« Reply #2 on: January 11, 2019, 04:44:42 am »
I'm sorry for digging out an old topic, but I need to ask if there are any news regarding the support for GLES 2.0?

 

anything