Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: No Window :/  (Read 4952 times)

0 Members and 1 Guest are viewing this topic.

Laurent

  • Administrator
  • Hero Member
  • *****
  • Posts: 32503
    • View Profile
    • SFML's website
    • Email
No Window :/
« Reply #15 on: January 29, 2010, 03:45:22 pm »
What about the SDK samples without Compiz?
Laurent Gomila - SFML developer

nowindow123

  • Newbie
  • *
  • Posts: 12
    • View Profile
No Window :/
« Reply #16 on: January 29, 2010, 03:50:46 pm »
Don't work, too (Same Problem) ;)

Laurent

  • Administrator
  • Hero Member
  • *****
  • Posts: 32503
    • View Profile
    • SFML's website
    • Email
No Window :/
« Reply #17 on: January 29, 2010, 04:05:48 pm »
Is it the 32 or 64-bits version of the OS?
Laurent Gomila - SFML developer

nowindow123

  • Newbie
  • *
  • Posts: 12
    • View Profile
No Window :/
« Reply #18 on: January 29, 2010, 04:12:32 pm »
32 bits  =)

Laurent

  • Administrator
  • Hero Member
  • *****
  • Posts: 32503
    • View Profile
    • SFML's website
    • Email
No Window :/
« Reply #19 on: January 29, 2010, 04:18:13 pm »
And you installed the 32-bits version of SFML, right?
Laurent Gomila - SFML developer

nowindow123

  • Newbie
  • *
  • Posts: 12
    • View Profile
No Window :/
« Reply #20 on: January 29, 2010, 04:19:44 pm »
Yes ;)

Laurent

  • Administrator
  • Hero Member
  • *****
  • Posts: 32503
    • View Profile
    • SFML's website
    • Email
No Window :/
« Reply #21 on: January 29, 2010, 04:24:16 pm »
No more idea in stock, sorry :D
Laurent Gomila - SFML developer

nowindow123

  • Newbie
  • *
  • Posts: 12
    • View Profile
No Window :/
« Reply #22 on: January 29, 2010, 04:24:56 pm »
Okay, i will look what i can do ;)
Thanks, anyway

hermitC

  • Newbie
  • *
  • Posts: 2
    • View Profile
    • http://www.blackgolem.com
Similar problem
« Reply #23 on: March 03, 2010, 02:12:41 am »
I'm using SFML since a halft year now, everything worked fine so far.

Yesterday I continued working on my game project. It has DLL and LIB configurations as well as debug and release configs (speak 4 different configurations). The last time (some weeks ago) I ran it everything worked. Now it does no longer show the graphical window. The console window pops up and the program freezes without showing the graphical window.

A quick assembler code step through showed that the code does not even enter the main function body. It loops endless somewhere in ntdll.dll - no debugging possible here.

This is true for all configurations linking to DLLs (release and debug). Configurations with static linking work. After some tests I found out that linking to sfml-window[-d].dll lets the program freeze. Running a program linked only to the System DLL works correctly.

Does anybody have the same problem? Sounds like a driver problem. I've updated my GC drivers (NVIDIA GeForce Go 7300) shortly, that did not solve the problem. Google does not have an answer either.
Blog: www.blackgolem.com
Steampunk shoot em up game: www.nordenfelt-thegame.com

hermitC

  • Newbie
  • *
  • Posts: 2
    • View Profile
    • http://www.blackgolem.com
No Window :/
« Reply #24 on: March 03, 2010, 02:57:25 am »
Forget it. Switched to SFML 1.5 and recompiled everything - now it works.

Switching could not be easier. Great lib!
Blog: www.blackgolem.com
Steampunk shoot em up game: www.nordenfelt-thegame.com

somehugenerd

  • Newbie
  • *
  • Posts: 1
    • View Profile
No Window :/
« Reply #25 on: August 09, 2010, 12:12:08 am »
Sorry to dredge up an old thread, but I just ran into a problem like this myself and figured I'd share the aftermath.  It didn't happen on any of my computers, but happened on a friends, so it took a while to figure out what was going on.

Seems like what happened was that I was setting the video mode manually to a mode which was not supported (for whatever reason) by my friend's computer, but was supported by mine.  Therefore when I tried to run it on mine, no problems, but on his the window didn't show up (even though the program was running properly according to the log output I was printing)

One quick way to see if that might be the problem you're having is to create the sf::RenderWindow with a default mode instead of manually setting the mode.  So like this:

Code: [Select]

sf::RenderWindow App(sf::VideoMode::GetMode(0), "SFML Graphics");


If that works, then for some stupid reason your computer doesn't want to handle 800x600x32 properly.   (1280x1024x32 was the mode I was trying to set on the friend's computer, so it boggled my mind that it didn't work properly)

In order to solve the problem, I logged a list of all the video modes supported on his computer, and just set it manually to one on the list.

Here's the code from the window tutorial that checks video modes:

Code: [Select]

unsigned int VideoModesCount = sf::VideoMode::GetModesCount();
for(unsigned int i = 0; i < VideoModesCount; ++i)
{
    sf::VideoMode Mode = sf::VideoMode::GetMode(i);

    // Mode is a valid video mode
}


Now, all the modes you get out of this should be valid, but if you are trying to set a mode manually, you'll want something more like this (also from window tutorial):

Code: [Select]

sf::VideoMode Mode(800, 600, 32);
if(!Mode.IsValid())
{
    // Display an error, or try a different mode or something...
}


Hope that helps!

 

anything