Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: Locked to 60 frames in fullscreen  (Read 279 times)

0 Members and 1 Guest are viewing this topic.


  • Newbie
  • *
  • Posts: 1
    • View Profile
    • Email
Locked to 60 frames in fullscreen
« on: July 19, 2019, 11:29:00 am »
Hey guys,
I am building the sample code for the green circle with vsync enabled (both in code and nvidia tool). I am using arch linux with newest driver and sfml distributed by the package manager. The problem I found, is the difference in frames I get, dependent on being in fullscreeen or not. This monitor can reach 144 fps and this works fine for windowed mode. But if I put the same code into fullscreen, it is locked to 60 fps. I checked it by using a coded fps counter and also the nvidia tool.

Unfortunately I do not know if this problem is caused by sfml itself. I will also ask in the arch linux forums for this kind of problem. But maybe someone can help :)

Edit: Some more information about the pc:
Code: [Select]
  Host: lev-ssd-arch Kernel: 5.2.1-arch1-1-ARCH x86_64 bits: 64
  Desktop: Gnome 3.32.2 Distro: Arch Linux
  Type: Desktop System: Dell product: OptiPlex 9020 v: 01
  serial: <root required>
  Mobo: Dell model: 0N4YC8 v: A00 serial: <root required> UEFI: Dell v: A12
  date: 05/06/2015
  Topology: Quad Core model: Intel Core i5-4590 bits: 64 type: MCP
  L2 cache: 6144 KiB
  Speed: 3293 MHz min/max: 800/3300 MHz Core speeds (MHz): 1: 3293 2: 3293
  3: 3293 4: 3293
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
  driver: N/A
  Device-2: NVIDIA GM107 [GeForce GTX 750] driver: nvidia v: 430.34
  Display: x11 server: X.org 1.20.5 driver: nvidia
  resolution: <xdpyinfo missing>
  OpenGL: renderer: GeForce GTX 750/PCIe/SSE2 v: 4.6.0 NVIDIA 430.34
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
  driver: snd_hda_intel
  Device-2: Intel 8 Series/C220 Series High Definition Audio
  driver: snd_hda_intel
  Device-3: NVIDIA driver: snd_hda_intel
  Sound Server: ALSA v: k5.2.1-arch1-1-ARCH
  Device-1: Intel Ethernet I217-LM driver: e1000e
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: 98:90:96:e3:91:ed
  Local Storage: total: 715.39 GiB used: 56.75 GiB (7.9%)
  ID-1: /dev/sda vendor: SK Hynix model: SH920 2.5 7MM 256GB
  size: 238.47 GiB
  ID-2: /dev/sdb vendor: SK Hynix model: SH920 2.5 7MM 256GB
  size: 238.47 GiB
  ID-3: /dev/sdc type: USB vendor: Western Digital
  model: WD My Passport 25F3 size: 238.44 GiB
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci
  ID-1: / size: 122.20 GiB used: 15.12 GiB (12.4%) fs: ext4 dev: /dev/sdc2
  System Temperatures: cpu: 34.0 C mobo: N/A gpu: nvidia temp: 30 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 40%
  Processes: 244 Uptime: 1h 43m Memory: 15.57 GiB used: 3.25 GiB (20.9%)
  Shell: bash inxi: 3.0.35

Edit2: The monitor is GSync compatible. It is called AOC g2460. The nvidia control panel also confirms that GSync is enabled and working.

Here is the link to the arch linux forums thread: https://bbs.archlinux.org/viewtopic.php?pid=1854729#p1854729

Many thanks in advance
« Last Edit: July 19, 2019, 12:18:56 pm by Lamarn »


  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Locked to 60 frames in fullscreen
« Reply #1 on: March 05, 2020, 01:11:39 am »
Try this: In the NVIDIA X Server Settings go to X Server Display Configuration, Advanced and make sure both  Force Composition Pipeline and Force Full Composition Pipeline are NOT selected.