Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: SFML cursor left border is broken  (Read 159 times)

0 Members and 1 Guest are viewing this topic.

FloweyTF

  • Newbie
  • *
  • Posts: 7
    • View Profile
SFML cursor left border is broken
« on: July 07, 2020, 12:50:29 am »
I have a sprite for a cursor, and is has a black outline. The left border of it is black, but it shows up as white. I'm on linux.

EDIT: after some more testing, it seem as if there are just random lines on my sprite
« Last Edit: July 07, 2020, 01:00:51 am by FloweyTF »

eXpl0it3r

  • SFML Team
  • Hero Member
  • *****
  • Posts: 9573
    • View Profile
    • development blog
    • Email
Re: SFML cursor left border is broken
« Reply #1 on: July 07, 2020, 09:05:14 am »
Are you using sf::Sprite or sf::Cursor?

For sf::Cursor, note the the warning in the documentation:
Quote
On Unix, the pixels are mapped into a monochrome bitmap: pixels with an alpha channel to 0 are transparent, black if the RGB channel are close to zero, and white otherwise.
Official FAQ: https://www.sfml-dev.org/faq.php
Nightly Builds: https://www.nightlybuilds.ch/
——————————————————————
Dev Blog: https://dev.my-gate.net/
Thor: http://www.bromeon.ch/libraries/thor/

FloweyTF

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: SFML cursor left border is broken
« Reply #2 on: July 07, 2020, 07:26:15 pm »
I'm using sf::Cursor. It states that on UNIX, it behaves like that, but didn't say UNIX like.

 

anything