Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: Tutorial example fails  (Read 313 times)

0 Members and 1 Guest are viewing this topic.

aqua

  • Newbie
  • *
  • Posts: 1
    • View Profile
Tutorial example fails
« on: March 31, 2024, 09:02:59 pm »
Problem solved using static libraries /static linkage


Hello,

I'm new to SFML and I'm following this tutorial (https://www.sfml-dev.org/tutorials/2.6/start-cb.php).
The problem I've found is that although I can compile without errors the example code (the one that shows a window with a green circle), when I run it in debug mode, the command shell shows the following message:

Process returned -1073741819 (0xC0000005)

As there might be problems of compatibility between compiler versions, I've built the libraries from source with cmake in order to ensure this is not the reason of the problem.

I'm running the program on

  • Windows 10
  • Compiler gcc (x86_64-posix-seh-rev0, Built by MinGW-W64 project) 8.1.0
  • SFML 2.6.1
  • IDE: CodeBlocks 20.03


I'm using the dynamic libraries and the linking process doesn't seem to be the reason of the problem because  it doesn't produce any errors.

Anyone that has an idea about this?

Thank you in advance

« Last Edit: March 31, 2024, 11:39:25 pm by aqua »