Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: ATI Graphic Card Issue  (Read 22384 times)

0 Members and 1 Guest are viewing this topic.

Brendon

  • Jr. Member
  • **
  • Posts: 83
    • View Profile
    • http://blendogames.com
ATI Graphic Card Issue
« Reply #15 on: January 22, 2011, 09:18:57 pm »
@WarHampster - is the ATI issue resolved in sfml 1.6?  I'm using sfml 1.5 and my users with ATI cards (radeon 4xxx-7xxx) are reporting my program isn't running.

Laurent

  • Administrator
  • Hero Member
  • *****
  • Posts: 32504
    • View Profile
    • SFML's website
    • Email
ATI Graphic Card Issue
« Reply #16 on: January 23, 2011, 11:11:54 am »
Quote
is the ATI issue resolved in sfml 1.6?

Nop.
Laurent Gomila - SFML developer

Wibbs

  • Newbie
  • *
  • Posts: 40
    • View Profile
ATI Graphic Card Issue
« Reply #17 on: January 23, 2011, 05:51:59 pm »
I could also do with knowing whether/when there is likely to be a fix to this, as it has the potential to be a deal breaker with using SFML.

Laurent

  • Administrator
  • Hero Member
  • *****
  • Posts: 32504
    • View Profile
    • SFML's website
    • Email
ATI Graphic Card Issue
« Reply #18 on: January 23, 2011, 06:44:03 pm »
There will of course be a fix, probably soon.
Laurent Gomila - SFML developer

WarHampster

  • Newbie
  • *
  • Posts: 4
    • View Profile
ATI Graphic Card Issue
« Reply #19 on: January 25, 2011, 04:15:06 am »
Quote from: "Laurent"
Quote
is the ATI issue resolved in sfml 1.6?

Nop.


Gah, I thought that the issue was only in SFML 2.0. In that case, add me to the list of people asking for a quick and dirty fix.

Spodi

  • Full Member
  • ***
  • Posts: 150
    • View Profile
    • http://www.netgore.com/
ATI Graphic Card Issue
« Reply #20 on: January 30, 2011, 05:44:47 am »
Quote from: "Laurent"
Hmm the only thing I can think about is to:
1- add a kind of sf::Init() function
2- move the creation of the global OpenGL contexts (in GlContext.cpp: referenceContext and defaultContext) to this function
3- bind the Init() function in CSFML and SFML.Net
4- call it at startup


Any updates on whether or not this approach will be implemented for a temporary fix?

Laurent

  • Administrator
  • Hero Member
  • *****
  • Posts: 32504
    • View Profile
    • SFML's website
    • Email
ATI Graphic Card Issue
« Reply #21 on: January 30, 2011, 10:21:29 am »
Quote
Any updates on whether or not this approach will be implemented for a temporary fix?

No it won't, I'm already working on the clean solution ;)
Laurent Gomila - SFML developer

Xyro

  • Jr. Member
  • **
  • Posts: 52
    • View Profile
ATI Graphic Card Issue
« Reply #22 on: February 13, 2011, 03:21:46 pm »
Whats the eta on the fix ?

Laurent

  • Administrator
  • Hero Member
  • *****
  • Posts: 32504
    • View Profile
    • SFML's website
    • Email
ATI Graphic Card Issue
« Reply #23 on: February 13, 2011, 03:27:08 pm »
Progressing very slowly, I have very little time to spend on SFML at the moment.
Laurent Gomila - SFML developer

Dlaor

  • Newbie
  • *
  • Posts: 15
    • View Profile
ATI Graphic Card Issue
« Reply #24 on: February 27, 2011, 06:35:11 pm »
So when is this issue going to be fixed? I'm participating in a game development competition and I wanted to choose SFML.NET as game engine... but it's freezing every time I want to test my game! Is there any way to get around this? If this doesn't get fixed soon I'm afraid I'm going to have to switch to another game engine  :cry:

Laurent

  • Administrator
  • Hero Member
  • *****
  • Posts: 32504
    • View Profile
    • SFML's website
    • Email
ATI Graphic Card Issue
« Reply #25 on: February 27, 2011, 08:54:32 pm »
Laurent Gomila - SFML developer

Dlaor

  • Newbie
  • *
  • Posts: 15
    • View Profile
ATI Graphic Card Issue
« Reply #26 on: March 02, 2011, 07:10:39 pm »
Quote from: "Laurent"
You can try this:
http://www.sfml-dev.org/forum/viewtopic.php?p=27975#27975

Yeah, I found that link already, it fixed the problem  :D

Systemator

  • Newbie
  • *
  • Posts: 2
    • View Profile
ATI Graphic Card Issue
« Reply #27 on: July 08, 2011, 10:32:14 pm »
so any progress on that ???

OniLinkPlus

  • Hero Member
  • *****
  • Posts: 500
    • View Profile
ATI Graphic Card Issue
« Reply #28 on: July 08, 2011, 11:45:00 pm »
Quote from: "Systemator"
so any progress on that ???
It's been fixed for over a month now.
I use the latest build of SFML2

Systemator

  • Newbie
  • *
  • Posts: 2
    • View Profile
ATI Graphic Card Issue
« Reply #29 on: July 09, 2011, 04:01:44 pm »
Quote from: "OniLink10"
Quote from: "Systemator"
so any progress on that ???
It's been fixed for over a month now.

great thx :)