Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: Problem configuring csfml2 with cmake  (Read 34645 times)

0 Members and 1 Guest are viewing this topic.

Shados

  • Newbie
  • *
  • Posts: 6
    • MSN Messenger - chaosshados@30gigs.com
    • AOL Instant Messenger - nazfellun
    • View Profile
    • ShadosNet
    • Email
Re: Problem configuring csfml2 with cmake
« Reply #45 on: May 30, 2013, 03:04:31 pm »
Setting SFML_ROOT to C:\Program Files (x86)\SFML, where `mingw32-make install` installed SFML to by default, didn't help - I'm getting exactly the same error output. The DLLs & .a files are definitely in there under bin/ and lib/, respectively.

Laurent

  • Administrator
  • Hero Member
  • *****
  • Posts: 32504
    • View Profile
    • SFML's website
    • Email
Re: Problem configuring csfml2 with cmake
« Reply #46 on: May 30, 2013, 03:06:43 pm »
How did you set SFML_ROOT? Have you cleared the CMake cache and tried again from scratch?
Laurent Gomila - SFML developer

Shados

  • Newbie
  • *
  • Posts: 6
    • MSN Messenger - chaosshados@30gigs.com
    • AOL Instant Messenger - nazfellun
    • View Profile
    • ShadosNet
    • Email
Re: Problem configuring csfml2 with cmake
« Reply #47 on: May 30, 2013, 03:18:36 pm »
Here's what I did (from cmake-gui, with source/build directories set):
1. File->Delete Cache
2. Hit configure
3. Add Entry -> Name: SFML_ROOT, Type: Path, Value: C:/Program Files (x86)/SFML, left 'Description' blank
4. Hit configure again, get error output posted previously

Is there any other information you might need?

Laurent

  • Administrator
  • Hero Member
  • *****
  • Posts: 32504
    • View Profile
    • SFML's website
    • Email
Re: Problem configuring csfml2 with cmake
« Reply #48 on: May 30, 2013, 03:27:15 pm »
You must define SFML_ROOT before configuring.
Laurent Gomila - SFML developer

Shados

  • Newbie
  • *
  • Posts: 6
    • MSN Messenger - chaosshados@30gigs.com
    • AOL Instant Messenger - nazfellun
    • View Profile
    • ShadosNet
    • Email
Re: Problem configuring csfml2 with cmake
« Reply #49 on: May 30, 2013, 03:30:26 pm »
Alright, just tried deleting the cache & defining SFML_ROOT as before hitting configure, same error output q.q

Laurent

  • Administrator
  • Hero Member
  • *****
  • Posts: 32504
    • View Profile
    • SFML's website
    • Email
Re: Problem configuring csfml2 with cmake
« Reply #50 on: May 30, 2013, 03:40:47 pm »
Do you have a recent version of FindSFML.cmake? You should check inside if the name of the variable is SFML_ROOT; a while ago it was a different name.
Laurent Gomila - SFML developer

Shados

  • Newbie
  • *
  • Posts: 6
    • MSN Messenger - chaosshados@30gigs.com
    • AOL Instant Messenger - nazfellun
    • View Profile
    • ShadosNet
    • Email
Re: Problem configuring csfml2 with cmake
« Reply #51 on: May 30, 2013, 03:45:11 pm »
Yep, the name of the variable used in FindSFML.cmake on my system is SFML_ROOT.

Just tested something a friend mentioned to me, and manually setting the SFML_..._LIBRARY_RELEASE variables to their respective .a file paths and the SFML_INCLUDE_DIR path appropriately does let the configure/generation process work, and I can compile from that. Hope that helps?

Laurent

  • Administrator
  • Hero Member
  • *****
  • Posts: 32504
    • View Profile
    • SFML's website
    • Email
Re: Problem configuring csfml2 with cmake
« Reply #52 on: May 30, 2013, 03:47:55 pm »
Yes it works, but it's not a clean solution. find_package(SFML) should work.
Laurent Gomila - SFML developer