Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: SFMLUploads.Org [OFFLINE]  (Read 32860 times)

0 Members and 1 Guest are viewing this topic.

Lokk

  • Full Member
  • ***
  • Posts: 228
    • View Profile
    • http://betadineproject.wordpress.com/
[RELEASED] SFMLUploads.Org
« Reply #15 on: June 14, 2011, 11:14:59 pm »
Really good initiative and nice work !  8)

I started playing with the website, but I noticed a display error when the logout link is hovered (Chrome 12).

When you move your mouse over, the link goes bold and moves to the line below, which makes the click impossible.

Haikarainen

  • Hero Member
  • *****
  • Posts: 545
    • MSN Messenger - fredrik.haikarainen@gmail.com
    • View Profile
    • Email
[RELEASED] SFMLUploads.Org
« Reply #16 on: June 15, 2011, 12:50:44 am »
Quote from: "Lokk"
Really good initiative and nice work !  8)

I started playing with the website, but I noticed a display error when the logout link is hovered (Chrome 12).

When you move your mouse over, the link goes bold and moves to the line below, which makes the click impossible.


Thanks, I've meant to fix that(didn't know it was unclickable tho), but since my username Haikarainen is kinda wide(logout goes one line down either way), i've forgot it. It is fixed now by inserting a sweet <br /> :)

David

  • Jr. Member
  • **
  • Posts: 71
    • View Profile
SWEET!
« Reply #17 on: June 15, 2011, 01:05:14 pm »
This is amazing

I can finally upload stuff to a website that's not blocked :D

Couple of bugs:

1. When you upload an image with a transparent background, some weird black squares covers it up

2. How the heck can you share the uploads? (EDIT: I figured it out)

Here it is:
https://legacy.sfmluploads.org/cache/pics/18_USFML%20Logo.png
(with the weird black squares)

And here's the cleaner version:

https://legacy.sfmluploads.org/getpic.php?id=18

For some reason, the edges look a little aliased, but shrinking it would make it better

Haikarainen

  • Hero Member
  • *****
  • Posts: 545
    • MSN Messenger - fredrik.haikarainen@gmail.com
    • View Profile
    • Email
Re: SWEET!
« Reply #18 on: June 15, 2011, 04:54:33 pm »
Quote from: "David"
This is amazing

I can finally upload stuff to a website that's not blocked :D

Couple of bugs:

1. When you upload an image with a transparent background, some weird black squares covers it up

2. How the heck can you share the uploads? (EDIT: I figured it out)

Here it is:
https://legacy.sfmluploads.org/cache/pics/18_USFML%20Logo.png
(with the weird black squares)

And here's the cleaner version:

https://legacy.sfmluploads.org/getpic.php?id=18

For some reason, the edges look a little aliased, but shrinking it would make it better


Thanks alot :) I have (almost) fixed the issue now, the thumbnails will still have a black background for now(until ive fixex it), but the "whole" pics should look ok.

Regarding the uploads, I'm wondering if it is REALLY hard to figure that out, or were you just unfortunate? I want everyone to know how to use this site :P

Edit; Belive it or not, i cant really see the cleaner version, only the owners of the picture can download the original :P

David

  • Jr. Member
  • **
  • Posts: 71
    • View Profile
Re: SWEET!
« Reply #19 on: June 15, 2011, 08:28:28 pm »
Quote from: "Haikarainen"
Quote from: "David"
This is amazing

I can finally upload stuff to a website that's not blocked :D

Couple of bugs:

1. When you upload an image with a transparent background, some weird black squares covers it up

2. How the heck can you share the uploads? (EDIT: I figured it out)

Here it is:
https://legacy.sfmluploads.org/cache/pics/18_USFML%20Logo.png
(with the weird black squares)

And here's the cleaner version:

https://legacy.sfmluploads.org/getpic.php?id=18

For some reason, the edges look a little aliased, but shrinking it would make it better


Thanks alot :) I have (almost) fixed the issue now, the thumbnails will still have a black background for now(until ive fixex it), but the "whole" pics should look ok.

Regarding the uploads, I'm wondering if it is REALLY hard to figure that out, or were you just unfortunate? I want everyone to know how to use this site :P

Edit; Belive it or not, i cant really see the cleaner version, only the owners of the picture can download the original :P


Yea, I don't really care about the background being black, but it just looks too weird when it's only partially black and blocky  :wink:

On a side note, your website is AMAZING! :D  I can never get php to work on my computer, so my website is pretty much a dud. Keep up the good work!

EDIT: Now it looks just like the "cleaner" version

And about the uploads, it's because most websites where you upload images (such as imgur) have a link that says "Share"

I'm just spoiled by that, that's all. But it wouldn't hurt to make a "Share" button that creates a BBCode tag automatically for this forum. That would be awesome

EDIT: This is probably gonna be the last time I'll request stuff, but:

1. Can you temporarily keep the user logged in? Or make a remember username/login (It says "This site uses cookies" on the bottom  :wink: )

2. Can you have a "Delete" button with the file?

Haikarainen

  • Hero Member
  • *****
  • Posts: 545
    • MSN Messenger - fredrik.haikarainen@gmail.com
    • View Profile
    • Email
Re: SWEET!
« Reply #20 on: June 15, 2011, 08:53:24 pm »
Quote from: "David"

Yea, I don't really care about the background being black, but it just looks too weird when it's only partially black and blocky  :wink:

On a side note, your website is AMAZING! :D  I can never get php to work on my computer, so my website is pretty much a dud. Keep up the good work!

EDIT: Now it looks just like the "cleaner" version

And about the uploads, it's because most websites where you upload images (such as imgur) have a link that says "Share"

I'm just spoiled by that, that's all. But it wouldn't hurt to make a "Share" button that creates a BBCode tag automatically for this forum. That would be awesome

EDIT: This is probably gonna be the last time I'll request stuff, but:

-Can you temporarily keep the user logged in? Or make a remember username/login (It says "This site uses cookies" on the bottom  :wink: )



Thanks alot man :D Glad to hear my work is appreciated.

Regarding the sharethingy for pictures: Ill get right on that ;)

On your serverissue:
If you run windows, WAMP 2.0 is a very nice serversoftware kit.. Its basically Apache, PHP, MySQL and phpmyadmin in a simple installer.
If you run Linux, i can hint you that in debian(and probably ubuntu too), the following command installs all of it : "apt-get install mysql-server phpmyadmin", since phpmyadmin is dependent of apache and php with mysql-modules, and mysql-server installs a mysqlserver for it ;)


EDIT: Yeah, been thinking about that too, just gotta pull my finger out of my ass and find the session-timeout for php/apache :P

David

  • Jr. Member
  • **
  • Posts: 71
    • View Profile
Re: SWEET!
« Reply #21 on: June 15, 2011, 08:55:29 pm »
Quote from: "Haikarainen"
Quote from: "David"

Yea, I don't really care about the background being black, but it just looks too weird when it's only partially black and blocky  :wink:

On a side note, your website is AMAZING! :D  I can never get php to work on my computer, so my website is pretty much a dud. Keep up the good work!

EDIT: Now it looks just like the "cleaner" version

And about the uploads, it's because most websites where you upload images (such as imgur) have a link that says "Share"

I'm just spoiled by that, that's all. But it wouldn't hurt to make a "Share" button that creates a BBCode tag automatically for this forum. That would be awesome

EDIT: This is probably gonna be the last time I'll request stuff, but:

-Can you temporarily keep the user logged in? Or make a remember username/login (It says "This site uses cookies" on the bottom  :wink: )



Thanks alot man :D Glad to hear my work is appreciated.

Regarding the sharethingy for pictures: Ill get right on that ;)

On your serverissue:
If you run windows, WAMP 2.0 is a very nice serversoftware kit.. Its basically Apache, PHP, MySQL and phpmyadmin in a simple installer.
If you run Linux, i can hint you that in debian(and probably ubuntu too), the following command installs all of it : "apt-get install mysql-server phpmyadmin", since phpmyadmin is dependent of apache and php with mysql-modules, and mysql-server installs a mysqlserver for it ;)


EDIT: Yeah, been thinking about that too, just gotta pull my finger out of my ass and find the session-timeout for php/apache :P


I think I tried WAMP at some point. I might've lost it somehow :P
I'll try again. Someday I'll get it to work  :twisted:

EDIT: Another small thing: The thumbnail seems to crop the image instead of shrinking it

Haikarainen

  • Hero Member
  • *****
  • Posts: 545
    • MSN Messenger - fredrik.haikarainen@gmail.com
    • View Profile
    • Email
Re: SWEET!
« Reply #22 on: June 15, 2011, 09:04:58 pm »
Quote from: "David"
I think I tried WAMP at some point. I might've lost it somehow :P
I'll try again. Someday I'll get it to work  :twisted:


Hehe, fixed the share thing, hope its enough.

Testing if it works properly:


Edit: Yep thats true, looks good for screenshots and other images that have a filled content (nontransparent pixels). It basically crops the thumbnailsize in the middle of the picture.. Try uploading a real screenshot

David

  • Jr. Member
  • **
  • Posts: 71
    • View Profile
Re: SWEET!
« Reply #23 on: June 15, 2011, 09:06:03 pm »
Quote from: "Haikarainen"
Quote from: "David"
I think I tried WAMP at some point. I might've lost it somehow :P
I'll try again. Someday I'll get it to work  :twisted:


Hehe, fixed the share thing, hope its enough.

Testing if it works properly:


Nice, nice, I'm starting to like it even more already :D

Make it link to the URL the image is on, so people can see it's full size



Wah, it's broken o_o



Jaja, it's just me :P

Haikarainen

  • Hero Member
  • *****
  • Posts: 545
    • MSN Messenger - fredrik.haikarainen@gmail.com
    • View Profile
    • Email
Re: SWEET!
« Reply #24 on: June 15, 2011, 09:09:50 pm »
Quote from: "David"
Quote from: "Haikarainen"
Quote from: "David"
I think I tried WAMP at some point. I might've lost it somehow :P
I'll try again. Someday I'll get it to work  :twisted:


Hehe, fixed the share thing, hope its enough.

Testing if it works properly:


Nice, nice, I'm starting to like it even more already :D

Make it link to the URL the image is on, so people can see it's full size



It does, to prove it ive uploaded my desktop background:
Edited  out because of potential abusive content

Guess i have to replace " " with "%20" tho, to make your link work EDIT : Done

David

  • Jr. Member
  • **
  • Posts: 71
    • View Profile
[RELEASED] SFMLUploads.Org
« Reply #25 on: June 15, 2011, 09:12:06 pm »
No, but I don't know why it does that o_o (read my previous post)

And that is SOME background you got there xD



EDIT: Holy shnap, you were right about the %20 thing :shock:

Groogy

  • Hero Member
  • *****
  • Posts: 1470
    • MSN Messenger - groogy@groogy.se
    • View Profile
    • http://www.groogy.se
    • Email
[RELEASED] SFMLUploads.Org
« Reply #26 on: June 15, 2011, 09:21:52 pm »
I see someone like The Bg Bang Theory :P

Dock tror det inte är så appropiate att visa den här på forumet.
Developer and Maker of rbSFML and Programmer at Paradox Development Studio

Haikarainen

  • Hero Member
  • *****
  • Posts: 545
    • MSN Messenger - fredrik.haikarainen@gmail.com
    • View Profile
    • Email
[RELEASED] SFMLUploads.Org
« Reply #27 on: June 15, 2011, 09:42:32 pm »
Quote from: "Groogy"
I see someone like The Bg Bang Theory :P

Dock tror det inte är så appropiate att visa den här på forumet.


Hehe, she's hawt :P tror du har rätt

lakunar

  • Newbie
  • *
  • Posts: 20
    • View Profile
[RELEASED] SFMLUploads.Org
« Reply #28 on: June 15, 2011, 11:37:13 pm »
I found a display bug: just search for " " or "ksks" and you see it.

And to make the search box a bit more user friendly:
Code: [Select]

<form method="post" action="index.php?page=search">
<input id="searchbar" value="Search.." type="text" name="q"
     onfocus="if (this.value == 'Search..') {this.value = '';}"
     onblur= "if (this.value == '') {this.value = 'Search..';}"/>
</form>

Haikarainen

  • Hero Member
  • *****
  • Posts: 545
    • MSN Messenger - fredrik.haikarainen@gmail.com
    • View Profile
    • Email
[RELEASED] SFMLUploads.Org
« Reply #29 on: June 15, 2011, 11:45:18 pm »
Quote from: "lakunar"
I found a display bug: just search for " " or "ksks" and you see it.

And to make the search box a bit more user friendly:
Code: [Select]

<form method="post" action="index.php?page=search">
<input id="searchbar" value="Search.." type="text" name="q"
     onfocus="if (this.value == 'Search..') {this.value = '';}"
     onblur= "if (this.value == '') {this.value = 'Search..';}"/>
</form>


Thanks! Fixed the searchbar, also the display error. Gotta fix empty querys when i have time. EDIT: Fixed, apparently i dont have a lot of stuff to do this very evening :P

Cheers