Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: Antialiasing via ContextSettings not working on Linux  (Read 1676 times)

0 Members and 1 Guest are viewing this topic.


  • Newbie
  • *
  • Posts: 36
    • View Profile
Antialiasing via ContextSettings not working on Linux
« on: January 03, 2012, 10:01:14 pm »

the project I am working on uses vertex arrays and shapes a lot, but they aren't drawn with antialiasing, which makes them look quite ugly when they aren't made of axis-aligned lines. When I set ContextSettings' AntialisingLevel to 2 or 4 and create a RenderWindow with that, GetSettings().AntialisingLevel returns 0. I'm using CrunchBang Linux 10 and a rather recent version of SFML2. glxinfo and experience with various games on Linux tell me that my NVIDIA Linux drivers support antialiasing/multisampling up to level 4.
I have found something that might be related to the problem I'm having, but the thread is already over half a year old and the issue didn't seem to be solved yet: http://www.sfml-dev.org/forum/viewtopic.php?t=4462
Laurent described the situation as complicated, but the ability to enforce antialiasing through some function would be nice to have, though I have no idea how GLX, X11, Contexts and stuff like this work as I never worked with anything lying below SFML, so I might be underestimating the complexity in implementating something like this.

Any kind of help with or solution to this problem would be greatly appreciated.


  • Administrator
  • Hero Member
  • *****
  • Posts: 32504
    • View Profile
    • SFML's website
    • Email
Antialiasing via ContextSettings not working on Linux
« Reply #1 on: January 03, 2012, 10:17:38 pm »
It is indeed related to the issue that you found, and there's still no simple solution to the problem, as described in the task tracker issue.
Laurent Gomila - SFML developer