Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: linking on vs8  (Read 5393 times)

0 Members and 1 Guest are viewing this topic.

liljip

  • Newbie
  • *
  • Posts: 1
    • View Profile
linking on vs8
« on: September 12, 2007, 03:33:59 pm »
Hello, its the first time i use an external library. I'm doing it on visual studio8.
I followed the tutorials on the site, but it does not link.

I just made a litte test program and try to use SFML/Window.
For debug purpose i added all the libraries as "additional dependencies" (Linker/Input).

The errors are :
Code: [Select]

Error 1 error LNK2005: "public: virtual char const * __thiscall std::exception::what(void)const " (?what@exception@std@@UBEPBDXZ) already defined in LIBCMT.lib(stdexcpt.obj) MSVCRT.lib

Error 2 error LNK2005: "public: virtual __thiscall std::exception::~exception(void)" (??1exception@std@@UAE@XZ) already defined in LIBCMT.lib(stdexcpt.obj) MSVCRT.lib

Error 3 error LNK2005: "public: __thiscall std::exception::exception(void)" (??0exception@std@@QAE@XZ) already defined in LIBCMT.lib(stdexcpt.obj) MSVCRT.lib

Error 4 error LNK2005: "public: __thiscall std::exception::exception(char const * const &)" (??0exception@std@@QAE@ABQBD@Z) already defined in LIBCMT.lib(stdexcpt.obj) MSVCRT.lib

Error 5 error LNK2005: "public: __thiscall std::exception::exception(class std::exception const &)" (??0exception@std@@QAE@ABV01@@Z) already defined in LIBCMT.lib(stdexcpt.obj) MSVCRT.lib

Error 6 error LNK2005: __invalid_parameter_noinfo already defined in LIBCMT.lib(invarg.obj) MSVCRT.lib

Error 7 error LNK2005: "private: __thiscall type_info::type_info(class type_info const &)" (??0type_info@@AAE@ABV0@@Z) already defined in LIBCMT.lib(typinfo.obj) MSVCRT.lib

Error 8 error LNK2005: "private: class type_info & __thiscall type_info::operator=(class type_info const &)" (??4type_info@@AAEAAV0@ABV0@@Z) already defined in LIBCMT.lib(typinfo.obj) MSVCRT.lib

Warning 9 warning LNK4098: defaultlib 'MSVCRT' conflicts with use of other libs; use /NODEFAULTLIB:library MLibUI

Error 10 fatal error LNK1169: one or more multiply defined symbols found 1


By now the code just call Display() in sfWindow.

Any help would be greatly appreciated!

Cheers

Laurent

  • Administrator
  • Hero Member
  • *****
  • Posts: 32504
    • View Profile
    • SFML's website
    • Email
linking on vs8
« Reply #1 on: September 12, 2007, 03:46:08 pm »
In your project's properties, "C / C++", "Code generation", look at the value of "Runtime library". It must be set to :
- Multi-threaded Debug DLL (in Debug)
- Multi-threaded DLL (in Release)

But this should be the default.
Laurent Gomila - SFML developer

 

anything