Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: sfeMovie (video & audio playback library with many codecs)  (Read 78344 times)

0 Members and 1 Guest are viewing this topic.

gamepopper

  • Newbie
  • *
  • Posts: 35
    • View Profile
    • Email
Re: sfeMovie (video & audio playback library with many codecs)
« Reply #225 on: June 16, 2018, 12:33:28 am »
Ah I see... these were the ones set default in CMake:

theora;flac;vorbis;vp8;vp9;opus;adpcm_4xm;adpcm_adx;adpcm_afc;adpcm_ct;adpcm_dtk;adpcm_ea;adpcm_ea_maxis_xa;adpcm_ea_r1;adpcm_ea_r2;adpcm_ea_r3;adpcm_ea_xas;adpcm_g722;adpcm_g726;adpcm_g726le;adpcm_ima_amv;adpcm_ima_apc;adpcm_ima_dk3;adpcm_ima_dk4;adpcm_ima_ea_eacs;adpcm_ima_ea_sead;adpcm_ima_iss;adpcm_ima_oki;adpcm_ima_qt;adpcm_ima_rad;adpcm_ima_smjpeg;adpcm_ima_wav;adpcm_ima_ws;adpcm_ms;adpcm_sbpro_2;adpcm_sbpro_3;adpcm_sbpro_4;adpcm_swf;adpcm_thp;adpcm_thp_le;adpcm_vima;adpcm_xa;adpcm_yamaha;interplay_dpcm;pcm_alaw;pcm_bluray;pcm_dvd;pcm_f32be;pcm_f32le;pcm_f64be;pcm_f64le;pcm_lxf;pcm_mulaw;pcm_s16be;pcm_s16be_planar;pcm_s16le;pcm_s16le_planar;pcm_s24be;pcm_s24daud;pcm_s24le;pcm_s24le_planar;pcm_s32be;pcm_s32le;pcm_s32le_planar;pcm_s8;pcm_s8_planar;pcm_u16be;pcm_u16le;pcm_u24be;pcm_u24le;pcm_u32be;pcm_u32le;pcm_u8;pcm_zork;roq_dpcm;sol_dpcm;xan_dpcm

eXpl0it3r

  • SFML Team
  • Hero Member
  • *****
  • Posts: 9672
    • View Profile
    • development blog
    • Email
Re: sfeMovie (video & audio playback library with many codecs)
« Reply #226 on: June 16, 2018, 12:47:17 am »
Well, I don't see any AC3 or similar, just FLAC, OGG, Theora, Opus and PCM.
Official FAQ: https://www.sfml-dev.org/faq.php
Nightly Builds: https://www.nightlybuilds.ch/
——————————————————————
Dev Blog: https://dev.my-gate.net/
Thor: http://www.bromeon.ch/libraries/thor/

gamepopper

  • Newbie
  • *
  • Posts: 35
    • View Profile
    • Email
Re: sfeMovie (video & audio playback library with many codecs)
« Reply #227 on: June 16, 2018, 01:47:12 am »
Yeah I copied the string from SFEMOVIE_AVAILABLE_ENCODERS to SFEMOVIE_ENABLED_ENCODERS and now the videos work!