I'm really nobody to know C++ styles and standards, but in my view this is a case where the idea of operator overloading fails and named global functions should be used instead.
The "%" operator would be straightforward for integer modulo, but for any kind of division, "/" is too confusing, no matter which implementation you pick in the end. There are two good use cases for dividing times: one to calculate a ratio (floating point result), one to calculate the integer quotient or rounded down ratio (e.g. when turning seconds into minutes).
Both are equally common, I would guess, and therefore if SFML provides an operator for one case, it should provide one for the other case as well. Since you can't have "/" for both, maybe call them "Time::ratio" and "Time::quot" or something.
I'm not sure how painful this would be for C++ developers (I'm used to it coming from Java), so it's just my two cents on this.