Yes, but all the API starts with capitals. It would be incongruent to start without caps.
But float, int, double are lower case, so 2f seems better that 2F (I stress out the point about "2D" being 2-dimensions, and "2d" being 2-double-params, in OpenGL)
I like the current Vector/Rect notation because is verbose as the rest of the library functions (But not in an extreme way).
So don't you think it should be Vector/Rectangle (or Frame ?) ? It does look more logical to me.
Vector2f/Rectanglef is ok, yes. But I'm actually a conservative person...until stuff fails on me.
The "If it ain't broke, don't fix it" deal.