Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: Error when trying to use SFGUI with Visual Studio 2013  (Read 6225 times)

0 Members and 1 Guest are viewing this topic.

StormWingDelta

  • Sr. Member
  • ****
  • Posts: 365
    • View Profile
Error when trying to use SFGUI with Visual Studio 2013
« on: June 23, 2015, 10:46:55 pm »
No idea what is going on here. Just copy & pasted the helloworld example of theirs to test something and got this error;

Unhandled exception at 0x01FCB4D7 (ig4icd32.dll) in SFMLCPPGUITesting.exe: 0xC0000005: Access violation writing location 0x057A3000.
 


Here's the code if anyone wants it but not sure it is the code that is causing the problem. :(

(click to show/hide)

Was planning on checking if my setup to another class for using SFGUI was the issue but since I got the same error with their setup I'm not so sure of what is going on.  I'll post more useful info if needed later.
I have many ideas but need the help of others to find way to make use of them.

eXpl0it3r

  • SFML Team
  • Hero Member
  • *****
  • Posts: 10394
    • View Profile
    • development blog
    • Email
Re: Error when trying to use SFGUI with Visual Studio 2013
« Reply #1 on: June 23, 2015, 10:53:43 pm »
Google says it's something about your OpenGL driver etc.
Is it up to date? What GPU are you using?
Official FAQ: https://www.sfml-dev.org/faq.php
Official Discord Server: https://discord.gg/nr4X7Fh
——————————————————————
Dev Blog: https://dev.my-gate.net/

StormWingDelta

  • Sr. Member
  • ****
  • Posts: 365
    • View Profile
Re: Error when trying to use SFGUI with Visual Studio 2013
« Reply #2 on: June 23, 2015, 10:55:19 pm »
Google says it's something about your OpenGL driver etc.
Is it up to date? What GPU are you using?

No idea how to check that or update it if able. :(
I have many ideas but need the help of others to find way to make use of them.

eXpl0it3r

  • SFML Team
  • Hero Member
  • *****
  • Posts: 10394
    • View Profile
    • development blog
    • Email
Re: Error when trying to use SFGUI with Visual Studio 2013
« Reply #3 on: June 23, 2015, 10:59:51 pm »
Seriously? That's like Learning OS 101 - How to install, update and check your GPU driver... ::)

Go to the device manager and look there under graphics card. Then go to your graphics card vendor's website and check the driver version. Google should help you further...
Official FAQ: https://www.sfml-dev.org/faq.php
Official Discord Server: https://discord.gg/nr4X7Fh
——————————————————————
Dev Blog: https://dev.my-gate.net/

StormWingDelta

  • Sr. Member
  • ****
  • Posts: 365
    • View Profile
Re: Error when trying to use SFGUI with Visual Studio 2013
« Reply #4 on: June 23, 2015, 11:07:06 pm »
lol knew I was going to sound like an idiot but it is something I normally don't have to do often, Normally the Driver Booster program I got keeps these things up to date but it seems like it missed one. Going to be fun getting all of Intel's Drivers up to date. >_>
I have many ideas but need the help of others to find way to make use of them.

StormWingDelta

  • Sr. Member
  • ****
  • Posts: 365
    • View Profile
Re: Error when trying to use SFGUI with Visual Studio 2013
« Reply #5 on: June 24, 2015, 01:14:52 am »
Grabbing yet another driver updating program to see if it can update the 10 Driver Booster isn't updating.  If this doesn't work I'm going to go mental.  Any ideas for good programs to update drivers?  Testing out SlimDrivers this time to see if it can get the few Driver Booster isn't but if anyone has some ideas that might help.
I have many ideas but need the help of others to find way to make use of them.

eXpl0it3r

  • SFML Team
  • Hero Member
  • *****
  • Posts: 10394
    • View Profile
    • development blog
    • Email
Re: Error when trying to use SFGUI with Visual Studio 2013
« Reply #6 on: June 24, 2015, 01:18:07 am »
Just find out what hardware you've installed and get the drivers from the vendor's site. I really advise against such driver installers...
Official FAQ: https://www.sfml-dev.org/faq.php
Official Discord Server: https://discord.gg/nr4X7Fh
——————————————————————
Dev Blog: https://dev.my-gate.net/

StormWingDelta

  • Sr. Member
  • ****
  • Posts: 365
    • View Profile
Re: Error when trying to use SFGUI with Visual Studio 2013
« Reply #7 on: June 24, 2015, 01:32:24 am »
well the one I was using up til now was getting everything it was suppose to so it isn't all bad.  In any even normally I'd agree with you on avoiding them but in this case I'm only using them as last resorts since I can't find some of these drivers or vendors.  Also can't seem to find the correct driver that OpenGL is in on my computer and yes I've looked through the device manager. :(
I have many ideas but need the help of others to find way to make use of them.

StormWingDelta

  • Sr. Member
  • ****
  • Posts: 365
    • View Profile
Re: Error when trying to use SFGUI with Visual Studio 2013
« Reply #8 on: June 24, 2015, 03:39:49 pm »
OK I've updated everything I can think of to update and still can't get this error to go away. :(

I've been using the SFGUI from the nightly builds site so I've got little clue how to fix this problem at this point.
I have many ideas but need the help of others to find way to make use of them.

eXpl0it3r

  • SFML Team
  • Hero Member
  • *****
  • Posts: 10394
    • View Profile
    • development blog
    • Email
Re: Error when trying to use SFGUI with Visual Studio 2013
« Reply #9 on: June 24, 2015, 04:23:36 pm »
At best build SFML and SFGUI yourself and see if that works out.
Official FAQ: https://www.sfml-dev.org/faq.php
Official Discord Server: https://discord.gg/nr4X7Fh
——————————————————————
Dev Blog: https://dev.my-gate.net/

StormWingDelta

  • Sr. Member
  • ****
  • Posts: 365
    • View Profile
Re: Error when trying to use SFGUI with Visual Studio 2013
« Reply #10 on: June 25, 2015, 02:25:03 am »
Well if all else fails I can always make my own GUI Lib. :P Also after some hunting around I've found the current driver I got for intel graphics has a driver date of 05/26/2015.  Been checking around to see if there is a newer one before doing much.   Last I checked it was up to date so who knows.
I have many ideas but need the help of others to find way to make use of them.

dabbertorres

  • Hero Member
  • *****
  • Posts: 506
    • View Profile
    • website/blog
Re: Error when trying to use SFGUI with Visual Studio 2013
« Reply #11 on: June 25, 2015, 07:44:03 am »
Have you ran it step-by-step? So you can at least narrow it down to exactly which function call is causing the access violation.

Bonus points for getting debug libs of sfgui and tracing it down to where it happens in sfgui.

 

anything