Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: Missing DLL  (Read 6088 times)

0 Members and 1 Guest are viewing this topic.

boca500

  • Newbie
  • *
  • Posts: 6
    • View Profile
    • Email
Missing DLL
« on: March 01, 2016, 06:28:46 am »
After setting up SFML, and seemingly done correctly, I attempted to run a test program to make sure it is working.  However when I run this program it says APPCRT140D.dll is missing and DESKTOPCRT140D.dll is missing. Here is the test program I am running - http://pastebin.com/0PJ0BErQ

eXpl0it3r

  • SFML Team
  • Hero Member
  • *****
  • Posts: 10782
    • View Profile
    • development blog
    • Email
Missing DLL
« Reply #1 on: March 01, 2016, 07:38:37 am »
What compiler do you use?
Official FAQ: https://www.sfml-dev.org/faq.php
Official Discord Server: https://discord.gg/nr4X7Fh
——————————————————————
Dev Blog: https://duerrenberger.dev/blog/

jamesL

  • Full Member
  • ***
  • Posts: 124
    • View Profile

boca500

  • Newbie
  • *
  • Posts: 6
    • View Profile
    • Email
Re: Missing DLL
« Reply #3 on: March 03, 2016, 04:31:49 am »
What compiler do you use?
I use visual studio 2015, followed the official tutorial and done extensive research and it seems the dll's have been combined into one called ucrtbase.dll and ucrtbased.dll so why is it trying to use outdated dll's?

boca500

  • Newbie
  • *
  • Posts: 6
    • View Profile
    • Email
Re: Missing DLL
« Reply #4 on: March 03, 2016, 04:40:25 am »

http://stackoverflow.com/questions/32129787/visual-studio-2015-win10-appcrt140-dll-missing

looked over this however this is happening to me on blank programs while using no nuGet packages at all, unlike the person in that situation.

eXpl0it3r

  • SFML Team
  • Hero Member
  • *****
  • Posts: 10782
    • View Profile
    • development blog
    • Email
Re: Missing DLL
« Reply #5 on: March 03, 2016, 12:42:36 pm »
I still suggest to do a clean install of the official VS 2015 Community edition.
Official FAQ: https://www.sfml-dev.org/faq.php
Official Discord Server: https://discord.gg/nr4X7Fh
——————————————————————
Dev Blog: https://duerrenberger.dev/blog/

boca500

  • Newbie
  • *
  • Posts: 6
    • View Profile
    • Email
Re: Missing DLL
« Reply #6 on: March 03, 2016, 02:34:10 pm »
I still suggest to do a clean install of the official VS 2015 Community edition.

I have already tried this and my friend who just downloaded Visual Studio not but 5 min ago has the same problem.

eXpl0it3r

  • SFML Team
  • Hero Member
  • *****
  • Posts: 10782
    • View Profile
    • development blog
    • Email
Re: Missing DLL
« Reply #7 on: March 03, 2016, 02:36:43 pm »
Did you do a clean rebuild after the new fresh install?
Official FAQ: https://www.sfml-dev.org/faq.php
Official Discord Server: https://discord.gg/nr4X7Fh
——————————————————————
Dev Blog: https://duerrenberger.dev/blog/

boca500

  • Newbie
  • *
  • Posts: 6
    • View Profile
    • Email
Re: Missing DLL
« Reply #8 on: March 03, 2016, 02:41:30 pm »
Did you do a clean rebuild after the new fresh install?

Yes

boca500

  • Newbie
  • *
  • Posts: 6
    • View Profile
    • Email
Re: Missing DLL
« Reply #9 on: March 03, 2016, 03:06:46 pm »
Using the exact same steps I was able to get it to work just fine on my computer at school using Visual Studio 2012, I checked the system for the outdated dll's as it is an older computer and windows 7 vs my windows 10 but it is using the updated dll (ucrtbased.dll and ucrtbase.dll).  Should I just switch to the old 2012 or try and get it to work on 2015?