Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: Which SFML package to install from NuGet ?  (Read 2545 times)

0 Members and 1 Guest are viewing this topic.

Tigrou

  • Newbie
  • *
  • Posts: 15
    • View Profile
Which SFML package to install from NuGet ?
« on: February 17, 2017, 02:48:56 pm »
When I search "SFML" on NuGet I got the following packages :

- "SFML.Net" (2.1.5) By Laurent G

However there is also the following ones :

sfml-system
sfml-window
sfml-graphics
sfml-audio
sfml-network

They are also by Laurent G. but version is 2.4.0

Should I install "SFML.Net" package (which is outdated) or the individual (more recent) packages (only the one I need) ?
If it's better to install the individual packages, what is the purpose of "SFML.Net" package ?

« Last Edit: February 17, 2017, 04:35:00 pm by Tigrou »

eXpl0it3r

  • SFML Team
  • Hero Member
  • *****
  • Posts: 9573
    • View Profile
    • development blog
    • Email
Which SFML package to install from NuGet ?
« Reply #1 on: February 18, 2017, 03:18:15 pm »
We're not the maintainers of the NuGet packages, you might want to find out who it is and message them. ;)
Official FAQ: https://www.sfml-dev.org/faq.php
Nightly Builds: https://www.nightlybuilds.ch/
——————————————————————
Dev Blog: https://dev.my-gate.net/
Thor: http://www.bromeon.ch/libraries/thor/

Tigrou

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: Which SFML package to install from NuGet ?
« Reply #2 on: February 27, 2017, 01:17:19 am »
I found the answer :
- "SFML.Net" package => this is for C# / .NET
- the other packages (sfml-system, sfml-window, ...) => C++.
« Last Edit: March 07, 2017, 01:55:45 pm by Tigrou »