Welcome, Guest. Please login or register.

Author Topic: SFML.net audio crash problem  (Read 47 times)

0 Members and 1 Guest are viewing this topic.

bzuidgeest

  • Newbie
  • *
  • Posts: 1
    • View Profile
SFML.net audio crash problem
« on: December 03, 2018, 09:09:14 pm »
Hello,

I have been making my first steps using SFML.net. I started with some baby steps and after a little effort I have found a combination of dll's (csfml/sfml) that seems to work... mostly :(.

I can display graphics and input seems to work fine and such. However I cannot get the audio part to do anything good. Whatever I do I seem to get an error: The program '[17952] dotnet.exe' has exited with code -1073741819 (0xc0000005) 'Access violation'. But only if I use the audio classes.

Some information:
I use the sfml.net bindings as compiled from github by me.
I use the csfml 2.5 dlls from https://ci.appveyor.com/project/eXpl0it3r/csfml/build/artifacts
I use sfml dlls (2.5.1) from https://www.sfml-dev.org/download/sfml/2.5.1/
I use .net core 2.1/Visutl studio 2017/Windows 10.

The following code gives the error. Not much to that.
using SFML.Audio;
using System;

namespace Test.Core
{
    class Program
    {
        static void Main(string[] args)
        {
            SoundBuffer s = new SoundBuffer(".\\Alarm01.wav");
        }
    }
}

I have the same error on music. At the moment I'm using 64-bit dll with the any-cpu config, which works for graphics. I tried using x86 config with 32-bit dlls. But then it crashes out with no error at all. no exceptions, no nothing.

I might me missing something obvious here, but for the moment the forum or issue list did not provide me with an answer I could use.

Any help appreciated.

 

anything