Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: [solved] Problem with SFML-wxWidgets  (Read 3509 times)

0 Members and 1 Guest are viewing this topic.

Olaf

  • Newbie
  • *
  • Posts: 1
    • View Profile
[solved] Problem with SFML-wxWidgets
« on: May 21, 2010, 12:24:11 am »
I tried to get the code from the tutorial for wxWidgets to run, but I got problems with it.

Compiling SFML or wxWidgets-Code alone works, but when I try using both of them Eclipse+CDT either can't resolve the inclusion of <SFML/Graphics.hpp> or <wx/wx.h>.

I guess this is because of wrong project settings. I configured SFML via http://razoras.livejournal.com/36934.html#cutid1 and wxWidgets via http://max.berger.name/howto/wxWidgets/wxWidgets_Eclipse.jsp . As I said, both of them work alone.

For the tutorial I took one of the setups as a base and added the settings for the other one.

These are my exact settings (project properties - C/C++ Build - Settings):
Code: [Select]
GCC C++ Compiler - Command line pattern: ${COMMAND} ${FLAGS} ${OUTPUT_FLAG} ${OUTPUT_PREFIX} ${OUTPUT} ${INPUTS}

   Directories: ...\sfml-1.6\include
                 ...\wxWidgets-2.8.11\lib\wx\include\msw-unicode-release-static-2.8
                 ...\wxWidgets-2.8.11\include
                 ...\wxWidgets-2.8.11\contrib\include

   Miscellaneous: -c -fmessage-length=0 -I...\wxWidgets-2.8.11\lib\wx\include\msw-unicode-release-static-2.8 -I...\wxWidgets-2.8.11\include -I...\wxWidgets-2.8.11\contrib\include-D__WXMSW__

MinGW C++ Linker

   Libraries: mingw32
              sfml-graphics-d
              sfml-window-d
              sfml-system-d

              ...\sfml-1.6\lib

   Miscellaneous: -L...\wxWidgets-2.8.11\lib   -Wl,--subsystem,windows -mwindows ...\wxWidgets-2.8.11\lib\libwx_mswu-2.8.a -lwxregexu-2.8 -lwxexpat-2.8 -lwxtiff-2.8 -lwxjpeg-2.8 -lwxpng-2.8 -lwxzlib-2.8 -lrpcrt4 -loleaut32 -lole32 -luuid -lwinspool -lwinmm -lshell32 -lcomctl32 -lcomdlg32 -lctl3d32 -ladvapi32 -lwsock32 -lgdi32


... is just an abbreviation for the path on my fs.


Maybe someone can check it and/or post the correct settings.

Edit: It works now, I'm not sure why. Maybe the path-variable wasn't set correctly before, although I already did log out and in. Anyway, it's fine!

 

anything