Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: SFML Warning  (Read 211 times)

0 Members and 1 Guest are viewing this topic.

strikeblack91

  • Newbie
  • *
  • Posts: 4
    • View Profile
    • Email
SFML Warning
« on: March 08, 2020, 01:21:39 pm »
Hello

I am a Epitech student and i have to create severals programs using sfml.
the problem is that when is start my program, some warnings appears and my program segfault randomly:

Warning: The created OpenGL context does not fully meet the settings that were requested
Requested: version = 2.0 ; depth bits = 0 ; stencil bits = 0 ; AA level = 0 ; core = false ; debug = false ; sRGB = true
Created: version = 4.6 ; depth bits = 0 ; stencil bits = 0 ; AA level = 0 ; core = false ; debug = false ; sRGB = true

But if i try my program on my friends computer, it works perfectly.
After have searched a lot on the internet, i ask your help...

help....

eXpl0it3r

  • SFML Team
  • Hero Member
  • *****
  • Posts: 9592
    • View Profile
    • development blog
    • Email
Re: SFML Warning
« Reply #1 on: March 08, 2020, 05:31:15 pm »
I always recommend to students to talk to their professor/assistant. They are being paid to help you, plus they know the parameters of the task a lot better.

What version of SFML are you using?
And what's your code?
Official FAQ: https://www.sfml-dev.org/faq.php
Nightly Builds: https://www.nightlybuilds.ch/
——————————————————————
Dev Blog: https://dev.my-gate.net/
Thor: http://www.bromeon.ch/libraries/thor/

strikeblack91

  • Newbie
  • *
  • Posts: 4
    • View Profile
    • Email
Re: SFML Warning
« Reply #2 on: March 09, 2020, 10:10:46 am »
Hello

Thanks you for your answer. I am in a private school, which is new in Berlin and .. there is few assistants and they don't konw all the problems of all the libraries that we use ...

I actually don'tknow the command ot get the exact version of the sfml, but I just resinstalled the SFML yesterday, and updated it.
For exemple as code, i use the main test which should display a circle with she sames command lines : https://www.sfml-dev.org/tutorials/2.5/start-linux.php

And i get this compilation error :
/usr/bin/ld: main.o: in function `main':
main.cpp:(.text+0xfc): undefined reference to `sf::CircleShape::CircleShape(float, unsigned int)'
collect2: error: ld returned 1 exit status

This is one of my first problem ...

eXpl0it3r

  • SFML Team
  • Hero Member
  • *****
  • Posts: 9592
    • View Profile
    • development blog
    • Email
Re: SFML Warning
« Reply #3 on: March 09, 2020, 10:46:22 am »
Looks like you're not linking SFML or not in the correct order.
Official FAQ: https://www.sfml-dev.org/faq.php
Nightly Builds: https://www.nightlybuilds.ch/
——————————————————————
Dev Blog: https://dev.my-gate.net/
Thor: http://www.bromeon.ch/libraries/thor/

 

anything