Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: Help me please.  (Read 86 times)

0 Members and 1 Guest are viewing this topic.

3elDU

  • Newbie
  • *
  • Posts: 3
    • View Profile
    • Email
Help me please.
« on: July 08, 2020, 10:46:05 am »
I don't know, am I allowed to post this kind of posts here at the forum.
But i have problems with SFML and CodeBlocks.
I did everything as said here ( i used sfml project template ).
My Code::Blocks version is 20.03.
SFML version is GCC 5.1.0 TDM (SJLJ) - Code::Blocks - 32-bit.
I'm using dynamic link library.
Here's what i get:
-------------- Build: Debug in FuckingSFML3 (compiler: GNU GCC Compiler)---------------

g++.exe -Wall -g -std=c++17 -I"C:\Program Files\CodeBlocks\sfml\include" -c C:\C++\FuckingSFML3\main.cpp -o obj\Debug\main.o
g++.exe -L"C:\Program Files\CodeBlocks\sfml\lib" -o bin\Debug\FuckingSFML3.exe obj\Debug\main.o   -lmingw32 -luser32 -lgdi32 -lwinmm -ldxguid -lsfml-graphics-d -lsfml-window-d -lsfml-system-d
c:/gcc/bin/../lib/gcc/x86_64-w64-mingw32/10.1.0/../../../../x86_64-w64-mingw32/bin/ld.exe: skipping incompatible C:\Program Files\CodeBlocks\sfml\lib/libsfml-graphics-d.a when searching for -lsfml-graphics-d
c:/gcc/bin/../lib/gcc/x86_64-w64-mingw32/10.1.0/../../../../x86_64-w64-mingw32/bin/ld.exe: skipping incompatible C:\Program Files\CodeBlocks\sfml\lib\libsfml-graphics-d.a when searching for -lsfml-graphics-d
c:/gcc/bin/../lib/gcc/x86_64-w64-mingw32/10.1.0/../../../../x86_64-w64-mingw32/bin/ld.exe: skipping incompatible C:\Program Files\CodeBlocks\sfml\lib/libsfml-graphics-d.a when searching for -lsfml-graphics-d
c:/gcc/bin/../lib/gcc/x86_64-w64-mingw32/10.1.0/../../../../x86_64-w64-mingw32/bin/ld.exe: cannot find -lsfml-graphics-d
c:/gcc/bin/../lib/gcc/x86_64-w64-mingw32/10.1.0/../../../../x86_64-w64-mingw32/bin/ld.exe: skipping incompatible C:\Program Files\CodeBlocks\sfml\lib/libsfml-window-d.a when searching for -lsfml-window-d
c:/gcc/bin/../lib/gcc/x86_64-w64-mingw32/10.1.0/../../../../x86_64-w64-mingw32/bin/ld.exe: skipping incompatible C:\Program Files\CodeBlocks\sfml\lib\libsfml-window-d.a when searching for -lsfml-window-d
c:/gcc/bin/../lib/gcc/x86_64-w64-mingw32/10.1.0/../../../../x86_64-w64-mingw32/bin/ld.exe: skipping incompatible C:\Program Files\CodeBlocks\sfml\lib/libsfml-window-d.a when searching for -lsfml-window-d
c:/gcc/bin/../lib/gcc/x86_64-w64-mingw32/10.1.0/../../../../x86_64-w64-mingw32/bin/ld.exe: cannot find -lsfml-window-d
c:/gcc/bin/../lib/gcc/x86_64-w64-mingw32/10.1.0/../../../../x86_64-w64-mingw32/bin/ld.exe: skipping incompatible C:\Program Files\CodeBlocks\sfml\lib/libsfml-system-d.a when searching for -lsfml-system-d
c:/gcc/bin/../lib/gcc/x86_64-w64-mingw32/10.1.0/../../../../x86_64-w64-mingw32/bin/ld.exe: skipping incompatible C:\Program Files\CodeBlocks\sfml\lib\libsfml-system-d.a when searching for -lsfml-system-d
c:/gcc/bin/../lib/gcc/x86_64-w64-mingw32/10.1.0/../../../../x86_64-w64-mingw32/bin/ld.exe: skipping incompatible C:\Program Files\CodeBlocks\sfml\lib/libsfml-system-d.a when searching for -lsfml-system-d
c:/gcc/bin/../lib/gcc/x86_64-w64-mingw32/10.1.0/../../../../x86_64-w64-mingw32/bin/ld.exe: cannot find -lsfml-system-d
collect2.exe: error: ld returned 1 exit status
Process terminated with status 1 (0 minute(s), 4 second(s))
4 error(s), 0 warning(s) (0 minute(s), 4 second(s))
 

eXpl0it3r

  • SFML Team
  • Hero Member
  • *****
  • Posts: 9573
    • View Profile
    • development blog
    • Email
Re: Help me please.
« Reply #1 on: July 08, 2020, 10:50:19 am »
Instead of being uncertain about your post, you could read the forum rules, think about the category you originally posted in and use a proper thread title. ;)

Code::Blocks 20.03 ships with a different compile than the one used to build the SFML binaries on the download page. As such you have to rebuild SFML yourself with your given compiler.
Note also the red box on the download page. ;)
Official FAQ: https://www.sfml-dev.org/faq.php
Nightly Builds: https://www.nightlybuilds.ch/
——————————————————————
Dev Blog: https://dev.my-gate.net/
Thor: http://www.bromeon.ch/libraries/thor/

3elDU

  • Newbie
  • *
  • Posts: 3
    • View Profile
    • Email
Re: Help me please.
« Reply #2 on: July 08, 2020, 10:58:37 am »
Thanks for help. Sorry if i did something wrong.
I have never posted anything on the forums  :).

And one more question.
What IDE would you recommend for such newbie as me?
« Last Edit: July 08, 2020, 11:12:49 am by eXpl0it3r »