Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: (solved) I am back after a long pause, i need to reconfigure CodeBlocks  (Read 1736 times)

0 Members and 1 Guest are viewing this topic.

Power

  • Jr. Member
  • **
  • Posts: 70
    • View Profile
Hello,
I lost one hard drive called "D:\" last month, it has all my codes, i could try to get my files back but as for now the hard drive is dead.
It has also my "project templates".

I just reconfigured the libraries ( https://www.sfml-dev.org/tutorials/2.5/start-cb.php) and tried to run the test code :
#include <SFML/Graphics.hpp>

int main()
{
    sf::RenderWindow window(sf::VideoMode(200, 200), "SFML works!");
    sf::CircleShape shape(100.f);
    shape.setFillColor(sf::Color::Green);

    while (window.isOpen())
    {
        sf::Event event;
        while (window.pollEvent(event))
        {
            if (event.type == sf::Event::Closed)
                window.close();
        }

        window.clear();
        window.draw(shape);
        window.display();
    }

    return 0;
}


I get this error message :
(image)


Could someone help?
I tried to check on all codeblocks parameters and did not find anything related to "D:\", then i tried to check my windows variables (PATH stuff), same thing i did not see anything related SFML.
Thanks

« Last Edit: September 27, 2020, 09:17:50 pm by Power »

Power

  • Jr. Member
  • **
  • Posts: 70
    • View Profile
Re: I am back after a long pause, i need to reconfigure CodeBlocks
« Reply #1 on: September 27, 2020, 09:17:30 pm »
Found the solution :
I had added the "s" type library and the "non s" library aswell, i removed one and kept "\libsfml-graphics-d.a" and all 50 errors dissapeared.

 

anything