Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: [SOLVED, i am idiot] Music stops playing sometimes  (Read 288 times)

0 Members and 1 Guest are viewing this topic.

achpile

  • Full Member
  • ***
  • Posts: 229
    • View Profile
    • Achpile's homepage
    • Email
[SOLVED, i am idiot] Music stops playing sometimes
« on: January 20, 2021, 02:48:35 pm »
Good day. I've encountered a weird bug, which I have no idea how to reproduce in "small example"...
It happened in windows (built with mingw 32bit).

So I start music like this:

track->stop();
track->openFromFile(...);
track->setLoop(loop);
track->play();
track->setPlayingOffset(cache->musics[current]);
 

After this I added the log:
Loop = true
Offset = 4739
Length = 96000
 

So the output is getLoop(), getPlayingOffset() and getDuration().

And sometimes it just stops playing... I added a log:

Track loop = true
Offset = 0
Length = 96000
Status = Stopped
 

Have anyone had this bug, or have any ideas what could cause it? Thanks

achpile

  • Full Member
  • ***
  • Posts: 229
    • View Profile
    • Achpile's homepage
    • Email
Re: Music stops playing sometimes
« Reply #1 on: January 20, 2021, 02:54:35 pm »
I found this thread, but it looks dead
https://en.sfml-dev.org/forums/index.php?topic=25298

Did anyone found the solution?

achpile

  • Full Member
  • ***
  • Posts: 229
    • View Profile
    • Achpile's homepage
    • Email
Re: Music stops playing sometimes
« Reply #2 on: January 20, 2021, 03:36:48 pm »
Oh, sorry. My bad... I'm using old SFML version for windows build....

 

anything