Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: Very strange problem when launching my game.  (Read 1261 times)

0 Members and 1 Guest are viewing this topic.

PizzaBoy

  • Newbie
  • *
  • Posts: 4
    • View Profile
Very strange problem when launching my game.
« on: November 17, 2010, 06:12:57 am »
I have a small game with only a simple character and some blocks for him to jump on.

When launching the game from CodeBlocks or Command Prompt (with no parameters), or even a .bat file, the game runs correctly. However, if I launch the game by double clicking it in Windows Explorer, my character cannot move and his sprite blinks repeatedly (I have no animation code that could cause this).

I've never heard of a program behaving differently depending on if it was launched by Command Prompt or Explorer. Obviously, having to tell my friends to run the game from Command Prompt is not a good solution. Has any else had this problem?

Random information: I have Windows 7 64 bit. I am using static linking. The error occurs in both debug and release builds, with vertical sync on or off

Things that fix the error:
Running from Command Prompt.
Running from CodeBlocks.
Running from a .bat file.
Running with any compatibility option enabled (except running as administrator)

Edit- I put the game in dropbox (a file sync service) to have a friend try it, and it worked for him (same OS as me). But then I ran it from my dropbox folder and it worked. Then I ran it from my desktop and it worked. I guess the error is related to running it from my bin/Release folder?