Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: [SOLVED] Visual Studio 2008 Professional Problem  (Read 3405 times)

0 Members and 1 Guest are viewing this topic.

BloodGod

  • Newbie
  • *
  • Posts: 10
    • View Profile
[SOLVED] Visual Studio 2008 Professional Problem
« on: May 25, 2008, 10:02:24 pm »
Hi there =)

I've just installed VS 2008 Prof. and tried to make a Project with SFML...

Everything works find except, when starting the .exe, this message shows up and the programm terminates:





I try to run this code:
Code: [Select]

#include "stdafx.h" //stdafx: #include <SFML/System.hpp>

int main()
{
    sf::Clock Clock;
    while (Clock.GetElapsedTime() < 5.f)
    {
        std::cout << Clock.GetElapsedTime() << std::endl;
        sf::Sleep(0.5f);
    }

    return 0;
}


Did I forget something? :(

Sincerely,
BloodGod

EDIT:
Ok, I see....I have to build the libs my self! Seems to work now =D.
And again: SFML dominates!
Verlässt du dich auf andere, bist du selbst verlassen ;)

dabo

  • Sr. Member
  • ****
  • Posts: 260
    • View Profile
    • http://www.dabostudios.net
[SOLVED] Visual Studio 2008 Professional Problem
« Reply #1 on: May 26, 2008, 08:26:45 am »
Isen't it funny how many times you solve the problems yourself the second after you post at a forum. :) Can't remember how many times I have done that myself.

workmad3

  • Jr. Member
  • **
  • Posts: 71
    • View Profile
[SOLVED] Visual Studio 2008 Professional Problem
« Reply #2 on: May 27, 2008, 03:41:41 pm »
Yup :) I try not to post problems until I've been stuck on them for about a day nowadays... and I still end up solving them about a minute after posting :)

I think it's something to do with the thought process required to articulate the problem. You go through it, then you suddenly realise which step you haven't tried yet and that solves it :)

model76

  • Full Member
  • ***
  • Posts: 231
    • View Profile
[SOLVED] Visual Studio 2008 Professional Problem
« Reply #3 on: May 27, 2008, 08:16:57 pm »
Quote from: "workmad3"
...stuck on them for about a day nowadays... and I still end up solving them about a minute after posting :)
Seems like kind of a wast, don't it? Maybe posting the second the problem arises would be the better approach...  :wink:

If you post the solution it may even be useful :)

Metaby

  • Newbie
  • *
  • Posts: 23
    • View Profile
[SOLVED] Visual Studio 2008 Professional Problem
« Reply #4 on: May 30, 2008, 02:37:05 pm »
Hello, I had the same problem ago 1 or 2 month (atm of my beginning with sfml). I have copied the Static/Dynamic libs from 2005 (Express) into the lib folder in 2008 (Express). Now, it Works! =D
sry for my bad english^^
I hacked 127.0.0.1 *g*

 

anything