Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: SFML2: Audible 'clicks' with loud sounds in ogg format  (Read 1517 times)

0 Members and 1 Guest are viewing this topic.

Chèvre

  • Newbie
  • *
  • Posts: 20
    • View Profile
SFML2: Audible 'clicks' with loud sounds in ogg format
« on: June 05, 2011, 12:19:13 pm »

EDIT: never mind, I just noticed another thread was open about the same issue: http://www.sfml-dev.org/forum/viewtopic.php?t=2410


So I came across this really weird bug that only seems to affect Linux. I suspect it's most likely a problem with the ogg loading code/libraries.
I use Arch Linux and the latest SFML2 git snapshot.

My game uses ogg files for sound effects. A couple of them are quite loud, while others are quieter. Well, when played back, the loud ones produce clicks on Linux (not on Windows). I load sounds in a fairly normal fashion -- actually, just changing the sound file names in the standard 'sound' example yields the bug.

I first thought it was due to some problem with OpenAL and/or my audio config, but using the exact same sound effect as a wave file produces a perfect sound!

Also, if I 'un-amplify' the sound and then save it as an ogg file again, it won't click. (in a sound editor -- setting the sound volume through SFML doesn't take away the clicks)

It does that with music, too.

I don't really mind, because I can just make my sounds quieter. But I wonder if it has something to do with my set up, or if anyone else has had the same issue.

Here's the test program with the same sound in ogg and wav formats: http://dl.free.fr/qURMG7ZCo

 

anything