Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: Compiling SFML 2.0 error  (Read 2281 times)

0 Members and 1 Guest are viewing this topic.

Beta_Ravener

  • Jr. Member
  • **
  • Posts: 51
    • ICQ Messenger - 271426715
    • View Profile
Compiling SFML 2.0 error
« on: July 25, 2011, 12:31:58 pm »
I was trying to get SFML 2.0, read in this forum it should allow textures for shapes (is that so?).

Anyway I downloaded cmake to get VS project from that bunch of files, but I get "CMake Warning at cmake/Config.cmake:45 (message): Unsupported compiler" - strange because I have my VS2008 working, but what's worse I get:
Code: [Select]
CMake Error at C:/Program Files/CMake 2.8/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:91 (MESSAGE):
  Could NOT find Freetype (missing: FREETYPE_LIBRARY)
Call Stack (most recent call first):
  C:/Program Files/CMake 2.8/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:252 (_FPHSA_FAILURE_MESSAGE)
  C:/Program Files/CMake 2.8/share/cmake-2.8/Modules/FindFreetype.cmake:92 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  src/SFML/Graphics/CMakeLists.txt:62 (find_package)


Yes I've read the tutorial on how to build with cmake and there was told that windows shouldn't need anything installed before running cmake, and yes even though I've tried to install freetype 2.3.5 (through binary setup) and it didn't resolved problem. Running on Win7 just in case it matters. Thanks in advance.

Laurent

  • Administrator
  • Hero Member
  • *****
  • Posts: 32504
    • View Profile
    • SFML's website
    • Email
Compiling SFML 2.0 error
« Reply #1 on: July 25, 2011, 12:37:44 pm »
Quote
read in this forum it should allow textures for shapes (is that so?)

No, not yet.

Quote
CMake Warning at cmake/Config.cmake:45 (message): Unsupported compiler

Did you put your VS directory in the PATH before executing CMake (as explained in the tutorial)?
Laurent Gomila - SFML developer

Beta_Ravener

  • Jr. Member
  • **
  • Posts: 51
    • ICQ Messenger - 271426715
    • View Profile
Compiling SFML 2.0 error
« Reply #2 on: July 25, 2011, 12:51:55 pm »
I've run "your_visual_studio_folder\VC\bin\vcvars32.bat", however it seems it didn't added VS to the PATH, so I updated it with this line "C:\Program Files\Microsoft Visual Studio 9.0". However that doesn't get me rid of warning, but I think cmake would anyway ignore this, the real problem is with freetype. I had other errors also before but I've noticed that while running Comodo (security program), cmake fails to compile simple code, but after disabling it, I have just this freetype error.

And for those textures, I'd be glad if you could tell me if those are going to be added to Shape class so when time comes I can just specify a texture and other things, or is it planned other way?

Laurent

  • Administrator
  • Hero Member
  • *****
  • Posts: 32504
    • View Profile
    • SFML's website
    • Email
Compiling SFML 2.0 error
« Reply #3 on: July 25, 2011, 01:25:03 pm »
Quote
I've run "your_visual_studio_folder\VC\bin\vcvars32.bat", however it seems it didn't added VS to the PATH, so I updated it with this line "C:\Program Files\Microsoft Visual Studio 9.0\VC\bin". However that doesn't get me rid of warning

Can you describe what you did more precisely?

Quote
but I think cmake would anyway ignore this, the real problem is with freetype

CMake will find Freetype's libraries based on the compiler. So... don't try to fix anything else until CMake finds your compiler, it's all related.
Laurent Gomila - SFML developer

Beta_Ravener

  • Jr. Member
  • **
  • Posts: 51
    • ICQ Messenger - 271426715
    • View Profile
Compiling SFML 2.0 error
« Reply #4 on: July 25, 2011, 01:53:16 pm »
First I've run vcvars32.bat from windows explorer and started cmake through shortcut. It gave me these errors. Then I've tried eveything through VC2008 command prompt, first ran vcvars32.bat and then navigated to cmake folder and run it with cmake-gui. Same errors so lastly after your reply I've added VS2008 to PATH variable (on Win7 it can be found as described here: http://geekswithblogs.net/renso/archive/2009/10/21/how-to-set-the-windows-path-in-windows-7.aspx. I just added semicolon and full path to my VC directory. Ran everything again but the error persists.

Edit: Strange, but I've tried setting cmake to work with VC2005, then with VC10 (both errors ofcourse because of version mismatch), and then again with setting VC2008 and it was configured properly. Maybe a bug that shown just on my PC :?:

 

anything