By the way, how are the STL compatibility functions going to be named? begin() and end() are strictly speaking inconsistent, as they're missing "get"
The real problem however is, those standard iteration loops mostly use the iterator or const_iterator member type, at least in C++98 without type inference. So only providing begin() and end() isn't enough.
for (Container::iterator itr = c.begin(); itr != c.end(); ++itr)
But if sf::String and sf::VertexArray use iterator and const_iterator instead of Iterator and ConstIterator, you will have multiple naming conventions in your public API again