Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: Warnings...  (Read 7708 times)

0 Members and 1 Guest are viewing this topic.

Pwndja

  • Jr. Member
  • **
  • Posts: 54
    • View Profile
Warnings...
« on: September 09, 2007, 11:57:34 pm »
Hey I get these warnings of linker errors when i compile

Warning   1   warning LNK4098: defaultlib 'MSVCRT' conflicts with use of other libs; use /NODEFAULTLIB:library   Pong   

Warning   3   warning LNK4099: PDB 'vc80.pdb' was not found with 'C:\Program Files\Microsoft Visual Studio 8\VC\lib\sfml-Graphics-d.lib' or at 'c:\Documents and Settings\Jeb\Desktop\test pong\Pong\debug\vc80.pdb'; linking object as if no debug info   sfml-Graphics-d.lib   


I know I have used /NODEFAULTLIB:library before and all i did was make a list of libs that had conflicts in additional library directories with the /NODEFAULTLIB: preceding the list of conflicting libs... I was wondering if anyone could give me the list of libs that might be conflicting?


Also when I compile with the none debug libs such as sfml-Graphics.lib sfml-window.lib sfml-system.lib sfml-audio.lib When I run the .exe it throws errors and prompts for the debug... If i throw in the -d at the end of all the lib dependencies i.e sfml-Graphics-d.lib sfml-window-d.lib sfml-system-d.lib sfml-audio-d.lib then the .exe runs fine... but if i am going to release the code to my friends i don't want them to have to have the debug libs to run it any ideas?

Pwndja

  • Jr. Member
  • **
  • Posts: 54
    • View Profile
One Warning Fixed
« Reply #1 on: September 10, 2007, 12:15:44 am »
Here is the web site that tells you how to fix this error

Warning 1 warning LNK4098: defaultlib 'MSVCRT' conflicts with use of other libs; use /NODEFAULTLIB:library

http://www.stanford.edu/~yljiang/pages/GPRS%20Linking%20Warning.htm

Just find in the table what run-time lib you want to use ie.

Debug Multithreaded using DLL (msvcrtd.lib)

and then the list of libs to type into your  /Project/Setting/Link/Input/Ignore Specific Libraries

libc.lib, libcmt.lib, msvcrt.lib, libcd.lib, libcmtd.lib


I still dont know what will solve this error tho

Warning   2   warning LNK4099: PDB 'vc80.pdb' was not found with 'C:\Program Files\Microsoft Visual Studio 8\VC\lib\sfml-audio-d.lib' or at 'c:\Documents and Settings\Jeb\Desktop\test pong\Pong\debug\vc80.pdb'; linking object as if no debug info   sfml-audio-d.lib

Pwndja

  • Jr. Member
  • **
  • Posts: 54
    • View Profile
Figured the out the last warning
« Reply #2 on: September 10, 2007, 01:09:32 am »
Hey lol I hope someone else will benefit from all my posts... I figure out how to solve the last warning the

Warning 2 warning LNK4099: PDB 'vc80.pdb' was not found with ; linking object as if no debug info sfml-audio-d.lib

 I just changed all the Linker/Input/Added Dependants library to their none debug ones ie. sfml-Graphics.lib as oppose to sfml-Graphics-d.lib and then set configurations of the project to Release then re-built the project and all the warnings went away. :)

O some other settings too where
(C/C++)/Code Generation/runtime libraries set to Multi-threaded DLL (/MD)
and
Linker/general/Endable Incrementals Linking set to No (/INCREMENTAL:NO)


But the problem still holds when I try and compile the code in debug mode... it just gets fixed when I put in on release and the settings above

Laurent

  • Administrator
  • Hero Member
  • *****
  • Posts: 32504
    • View Profile
    • SFML's website
    • Email
Warnings when trying to compile in debug mode
« Reply #3 on: September 10, 2007, 09:17:42 am »
Quote
But the problem still holds when I try and compile the code in debug mode...

Do you mean you still get errors when linking in debug mode with debug libraries (-d) ? Which errors ?
Laurent Gomila - SFML developer