Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: error help (SFML 1.6)  (Read 737 times)

0 Members and 1 Guest are viewing this topic.

xDancinPoptartx

  • Newbie
  • *
  • Posts: 1
    • View Profile
    • Email
error help (SFML 1.6)
« on: August 06, 2012, 11:23:44 pm »
I keep getting a undefined error for sf::Window
#include <SFML/window.hpp>
int main(int argc, char** argv)
{
    sf::Window App(sf::VideoMode(640, 480, 32), "Everything");
    bool running = true;
    while(running)
    {
        App.Display();
    }
    return EXIT_SUCCESS;
}
 
« Last Edit: August 06, 2012, 11:26:53 pm by xDancinPoptartx »

eXpl0it3r

  • SFML Team
  • Hero Member
  • *****
  • Posts: 9941
    • View Profile
    • development blog
    • Email
Re: error help (SFML 1.6)
« Reply #1 on: August 07, 2012, 12:56:07 am »
The only thing I see wrong in your code is the SFML/window.hpp because it should be SFML/Window.hpp.
If that does not fix the error, then you haven't installed SFML right or setup your IDE right.

Btw I advice you to switch to SFML 2. ;)
Official FAQ: https://www.sfml-dev.org/faq.php
Nightly Builds: https://www.nightlybuilds.ch/
——————————————————————
Dev Blog: https://dev.my-gate.net/
Thor: http://www.bromeon.ch/libraries/thor/

Laurent

  • Administrator
  • Hero Member
  • *****
  • Posts: 32504
    • View Profile
    • SFML's website
    • Email
Re: error help (SFML 1.6)
« Reply #2 on: August 07, 2012, 08:00:55 am »
Would you mind giving more details?

What did you do? What are your linker settings? What is the exact error message?
Laurent Gomila - SFML developer