Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: Freetype malformed framework  (Read 1064 times)

0 Members and 1 Guest are viewing this topic.

typeoneerror

  • Newbie
  • *
  • Posts: 2
    • View Profile
Freetype malformed framework
« on: January 01, 2014, 01:32:17 am »
We just wrapped up a game in SFML for Mac and submitted it to the Mac store. We are using SFML 2.0. We're using a standard SFML project in Xcode with the link script that copies over the required frameworks. The game works great on all computers from Mac OSX 10.6-10.9. Trouble is, when we submit to the App Store, we get an email back saying the following:

Quote
Malformed Framework - The framework bundle (Shibashiba.app/Contents/Frameworks/freetype.framework) must contain a symbolic link 'freetype' -> 'Versions/Current/freetype'. Refer to the Anatomy of Framework Bundles for more information.

If I go into the Archived application, the freetype.framework folder is in Contents/Frameworks and it has a symbolic link that points to Versions/Current/freetype, so I'm at a loss as to what this error means. Could it be some kind of permissions error? Could the freetype distro included with 2.0 be messed up in some way? Any help would be appreciated. This is our last hurdle to shipping!

typeoneerror

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Freetype malformed framework
« Reply #1 on: January 02, 2014, 05:55:54 am »
Pretty sure the freetype framework is incorrectly set up. I've answered a question on stack overflow on why:

http://stackoverflow.com/questions/20864559/malformed-freetype-framework-in-sfml-mac-app/20876352#20876352

Also filed a bug on github just in case any one else runs into this issue.

kipbits

  • Newbie
  • *
  • Posts: 46
    • View Profile
    • https://en.sfml-dev.org/forums/index.php?action=profile;u=15614
Re: Freetype malformed framework
« Reply #2 on: December 14, 2015, 03:01:20 am »
I'm wondering if I am having the same problem? I had an issue with a code-siginig failure for freetype when signing my project. I fixed the error by using the flag --deep. But when I go to upload to the app store i get a validation error:

Couldn't find platform family in Info.plist CFBundleSupportedPlatforms or Mach-O LC_VERSION_MIN for A

any Ideas?

I've tried copy-pasting the linker commands
   cd /Library/Frameworks/freetype.framework
   ln -fns Versions/Current/freetype freetype
in the terminal. I still get the same error when I go to build and sign my project. What am I doing wrong?


addition:
   I've added a new thread for my related problem.
« Last Edit: December 14, 2015, 10:32:55 pm by kipbits »