Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: CSFML cmake broken?  (Read 17751 times)

0 Members and 1 Guest are viewing this topic.

rcurtis

  • Newbie
  • *
  • Posts: 19
    • View Profile
Re: CSFML cmake broken?
« Reply #45 on: September 25, 2014, 05:03:17 pm »
I am compiling the latest source from github for all 3 projects (SFML, CSFML, and the .NET bindings).  CSFML never makes it past the 'configure' step with CMake.

rcurtis

  • Newbie
  • *
  • Posts: 19
    • View Profile
Re: CSFML cmake broken?
« Reply #46 on: September 25, 2014, 05:59:02 pm »
My issue was solved (Thanks to Tank) by running the install target with SFML, clearing the CMake cache for the CSFML project, manually setting the SFML_ROOT var to the newly installed directory, and running configure again.

grok

  • Jr. Member
  • **
  • Posts: 67
    • View Profile
    • Email
Re: CSFML cmake broken?
« Reply #47 on: December 10, 2014, 08:23:03 pm »
I have another issue (I am running Ubuntu).
I built the latest SFML from the repository.
Now, when I try to build the latest CSFML I get this:
Quote
SFML found but version too low (requested: 2, found: 1.x.x)

I am absolutely sure that I have no SFML 1 installed. What am I doing wrong?
I tried to specify SFML_ROOT to the cmake but nothing changed.

Looks like it ignores SFML_ROOT I specified and as a result it uses "/usr/include/SFML/Config.hpp" which is from SFML 2.0 (previous version).
Weird.
« Last Edit: December 10, 2014, 08:56:32 pm by grok »

grok

  • Jr. Member
  • **
  • Posts: 67
    • View Profile
    • Email
Re: CSFML cmake broken?
« Reply #48 on: December 11, 2014, 07:10:19 am »
I specified both SFML_ROOT and SFML_INCLUDE_DIR and it worked.

now I am having the following:
Quote
/usr/bin/ld: warning: libsfml-window.so.2, needed by /usr/local/lib/libcsfml-window.so, not found (try using -rpath or -rpath-link)
/usr/bin/ld: warning: libsfml-system.so.2, needed by /usr/local/lib/libcsfml-window.so, not found (try using -rpath or -rpath-link)
/usr/bin/ld: warning: libsfml-graphics.so.2, needed by /usr/local/lib/libcsfml-graphics.so, not found (try using -rpath or -rpath-link)
/usr/bin/ld: warning: libsfml-audio.so.2, needed by /usr/local/lib/libcsfml-audio.so, not found (try using -rpath or -rpath-link)

Am I right that CSFML is not up-to-date? I mean, SFML is 2.2.0 while CSFML is 2.1?
Thank you for clarifications.

Laurent

  • Administrator
  • Hero Member
  • *****
  • Posts: 32418
    • View Profile
    • SFML's website
    • Email
Re: CSFML cmake broken?
« Reply #49 on: December 11, 2014, 08:16:53 am »
Indeed CSFML is not up-to-date, but this doesn't seem to be the problem.
Laurent Gomila - SFML developer

grok

  • Jr. Member
  • **
  • Posts: 67
    • View Profile
    • Email
Re: CSFML cmake broken?
« Reply #50 on: December 11, 2014, 08:46:30 am »
I see.
As a quick and dirty hack I renamed all the compiled libraries to match the version and my toy project finally recompiled OK. I understand that it is not the proper method to get around though.

UPD:
and, btw, FindSFML cmake config is not accurate. In case it finds the previous version of SFML (i.e. 2.1), it reports
Quote
SFML found but version too low (requested: 2, found: 1.x.x)
it should be
Quote
"... , found 2.1"
or alike.
« Last Edit: December 11, 2014, 09:36:38 am by grok »

Laurent

  • Administrator
  • Hero Member
  • *****
  • Posts: 32418
    • View Profile
    • SFML's website
    • Email
Re: CSFML cmake broken?
« Reply #51 on: December 11, 2014, 12:04:28 pm »
The script has been updated to match the new 2.2 versionning scheme, so there's a possibility that it no longer works well with previous versions. I'll report it and I'll keep you informed.
Laurent Gomila - SFML developer

 

anything